LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Communication error when attempting to compile FPGA

Highlighted

Hey all,

I've been having a problem when trying to compile an FPGA VI on a cRIO 9104 using Labview 2016.  It tries and fails to connect to the compile server, and it tells me that the Xilinx compilation tools aren't installed, though they are.  A screenshot of the windows is in the spoiler below.

Spoiler
error1.png

Using the same computer, I am able to compile a program from a seperate project on a cRIO 9063.  So I'm not sure if it's a compatibility issue with the 9104 or some other issue.  Any suggestions would be appreciated, thanks!

 

0 Kudos
Message 1 of 7
(1,551 Views)
Highlighted

Are you sure you have all the Xilinx tools installed? Different cRIOs require different versions of the Xilinx tool chain, and I think you have some options when you install them.

0 Kudos
Message 2 of 7
(1,545 Views)
Highlighted

Hello,

 

What operating system are you working on? Also, did you install the Xilinx Tools after installing LabVIEW and the FPGA module?

Austin
Product Support Engineer
National Instruments
0 Kudos
Message 3 of 7
(1,506 Views)
Highlighted

Apologies for the delay.  Yes, I beleive I have all the Xilinx tools installed.  The 2014 Labview worked fine until 2016 was installed on the same computer.  The OS I'm working on is Windows 7, though I would have to double check with a colleague who installed the 2016 version to know the order in which Xilinx was installed.  I assume it was after installing 2016 and the FPGA module.

 

 

0 Kudos
Message 4 of 7
(1,426 Views)
Highlighted

Hello,

 

Does the LabVIEW 2014 xilinx compiler still work, or do none of your LabVIEW versions work? 

 

With each version of LabVIEW, you should make sure to install the correct version of the Xilinx tools to match, as linked below.

 

http://www.ni.com/product-documentation/53056/en/

 

Best,

 

Shamik C

Applications Engineer 

National Instruments 

http://www.ni.com/support 

0 Kudos
Message 5 of 7
(1,405 Views)
Highlighted

Your problem is that the 9104 has a Virtex-II FPGA on it. Newer Xilinx versions have dropped support for those targets, so you'll need an old version installed too. As you can see from this page: http://www.ni.com/product-documentation/53056/en/ you'll need ISE 10.1, which can be downloaded here: http://www.ni.com/download/labview-fpga-module-2016/6233/en/

Cheers!

TJ G
0 Kudos
Message 6 of 7
(1,398 Views)
Highlighted

@ShamWOW!! wrote:

Hello,

 

Does the LabVIEW 2014 xilinx compiler still work, or do none of your LabVIEW versions work?


While I haven't touched the 2014 version much after the issue started, the projects that worked before on 2014 no longer compile either.  Projects using the cRIO 9063 compile just fine, just not on the 9104.

 

To verify I had everything installed, I did double check that the 2016 FPGA compilation tool was installed, and it is.  This also included me redownloading the 2016 tool, and running the setup where it said there was nothing new to install.

 

And thanks again for the assistance everyone!

0 Kudos
Message 7 of 7
(1,345 Views)