LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Communication between LabVIEW and Keithley 2400 with KUSB-488B under LabVIEW 2017 and Win7

Dear all!

I really want your help!!!!

 

I'm using Keithley 2400 through KUSB-488B GPIB-USB converter and my system is LabVIEW 2017 and Win7.

I checked NI visa interactive controller in NI-max and it works very well.

I confirmed keithley2400 respond "*IDN?" command and I can see my instrument in this menu absolutely.

 

The problem is I can't control it through LabVIEW!

I attached my VI and block diagram.

 

Is there any generous friend who can figure it out?

 

Thanks!

0 Kudos
Message 1 of 13
(2,744 Views)

Switch out the string with an actual visa resource. Right click on the visa resource input >> create control. Then select your resource from the dropdown if it is there.

 

You'll want to use Visa open and close before and after you communicate with the instrument.

0 Kudos
Message 2 of 13
(2,732 Views)

I tried but I can't find any instrument that I need.

GPIC address is 24.

0 Kudos
Message 3 of 13
(2,701 Views)

@winteriscoming wrote:

I tried but I can't find any instrument that I need.

GPIC address is 24.


 

That error...

 

error2

 

 

is telling you the comm port you DID NOT SELECT was invalid.

 

Find the device in Max and use the same port spec in your VISA resource name control.

 

Also be forwarned that not all of those Keithley 2400 are created equal. I have seen situation where an old model was replaced by a new version and the advanced settings or something worked differently. Consult the manual for the device you have.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 4 of 13
(2,698 Views)

I can find Ke2400 in NI-MAX and it communicates well.

Communication.jpgerror3.png

But when I try to find it in LabVIEW. I can't see anything.

0 Kudos
Message 5 of 13
(2,695 Views)

Well if it "refresh" does not find it, type in the device spec.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 6 of 13
(2,691 Views)

error4.jpg

 

It shows similar error message.

I guess this is  a problem of LabVIEW2017, because it communicates well with NI-MAX, is it right?

0 Kudos
Message 7 of 13
(2,687 Views)

I also checked HP4294A and it shows same error.

0 Kudos
Message 8 of 13
(2,679 Views)

Guessing now...

 

Are you including a termination character in your IDN command? Normally is carriage return (set to slash code display ... should show up as a \n.

 

If you have VISA installed then I would then ask about the drivers for your adapter being loaded.

 

NI IO Trace will let you spy on IO so you may want to run that while trying your test code. It may give you a clue.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 9 of 13
(2,671 Views)

I don't think the error is due to the termination character. The error message indicates it occurred in VISA Open.

I can't remember the exact circumstances, but there was one time "Refresh" wouldn't list all the resources. I had to use the VISA Find Resource function.  Try it and see if your resource shows up. This function is located in "Instrument IO -> VISA -> VISA Advanced"

 

find_VISA.png

Message 10 of 13
(2,664 Views)