LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Communicate with Instruments via TCP

Solved!
Go to solution

I am now getting another error at times, I can't quite figure out when and why this error will occur but it seems to be a more serious error in the sense that I can't recover from it without restarting the instrument.

 

Yesterday when everything was working fine (well I would occasionally get the lost connection error but could easily recover from it) I had my instrument plugged into a switch in the lab, and the PC talking to it was plugged into a different switch in the IT room.

 

This morning I connected the PC to the same switch that the instrument is plugged into and I kept getting the follwing error:

 

ConnectionError002.JPG

 

When this error occurs a simple close/open connection does not work. What else is interesting is that I can ping the instrument from my PC, but I can longer ping the PC from the instrument (this usually works fine), its like the instrument can no longer see the PC.

 

It took me a few minutes to realize that it might be the switch causing this problem, maybe some security feature built into it when it detects some strange communication that it assumes is not safe.

 

So I then plugged my PC back into the swith in the IT room, and everything is fine. So now to prove that my theory is correct, I plugged the PC back into the switch in the lab with the instrument to try and get the error again, but now I am not getting this "Insufficient location information" error again!

 

Any thoughts/ideas...?

 

Thanks for all your help 🙂

 

 

0 Kudos
Message 11 of 15
(431 Views)

This basically means that you can't find the device on the network. This will happen if you have no path to the device. Given the description you gave I would say that it is infrastructure related. There are tons of things that can limit this from an infrastructure perspective. Firewalls, port blocking, protocol blocking, MAC address filters, MAC address restrictions, basic port configuration, etc. THese are all infrastructure related settings. What type of switches are you connecting to? Are they managed switches or dump (usually consumer based) switches? Can you get network traces at both the device and the PC? This will help to isolate what it happening. Either way, the issue is not LabVIEW related.

 

BTW, what are the IP addresses for your PC and device? Are they DHCP assigned or static? When you connect to the same switch you can run into issues if they are on different subnets.



Mark Yedinak
Certified LabVIEW Architect
LabVIEW Champion

"Does anyone know where the love of God goes when the waves turn the minutes to hours?"
Wreck of the Edmund Fitzgerald - Gordon Lightfoot
0 Kudos
Message 12 of 15
(427 Views)

Hi Mark, thanks so much for your input. I agree I think that it does have something to do with the infrastructure. Also, when this error occurs, time is usually what fixes it. If left alone for long enough communicaion can begin again. This might be another clue as to what is going on.

 

IP Address of PC is: 192.168.1.157

Subnet Mask of PC is: 255.255.255.0

Default Gateway: 192.168.1.6

DHCP enabled: yes

 

IP Address of Instrument is: 192.168.1.152 - However in code I am using it's Hostname "LA-Agilent16702"

Subnet Mask of Instrument: 255.255.255.0

Gateway IP: <blank>

Networking setup of instrument is "Standard" as opposed to "DHCP" or "Disable" so I am assuming this is a static IP address. It is manually typed in.

 

The type of switch that the PC and instrument are connected to here in the labe is the following: 3COM #C17203 Super Stack 3


However from this switch the ethernet cable runs to the IT room and I am sure that there are other switches that it is plugged into.

 

When this error occurs what can I do to try to get more information about what is happening? How do I get a network trace?

 

Thanks so much for your help!

 

Anthony

 

0 Kudos
Message 13 of 15
(406 Views)

Hi Mark,

 

So I just got that error message. Both the PC were plugged into the same switch here in the lab. After getting the error message I could not get it to communicate with the instrument again. I then plugged the instrument directly into a racked switch in the IT room still no communication, I then plugged the PC ethernet cable also into the same racked switch into the IT room still no communication. 

 

I could not ping the PC from the intrument (I did not check to see if the PC could ping the instrument). I also disabled and re-enabled netwrok capability on the instrument this also did not help. However after restarting the instrument I could then ping the PC, and I could communicate with the instrument again. Does this point to the instrument or could it still be the network infrastructure?

 

Thanks so much

0 Kudos
Message 14 of 15
(400 Views)

I would look atthe instrument at this point. Also, you can download and install Wireshark on the PC to do the network capture. This will help to identify what is happening. If you use Wireshark to capture one of the failures I could take a quick look at the capture. Just post a response with the capture file attached.



Mark Yedinak
Certified LabVIEW Architect
LabVIEW Champion

"Does anyone know where the love of God goes when the waves turn the minutes to hours?"
Wreck of the Edmund Fitzgerald - Gordon Lightfoot
0 Kudos
Message 15 of 15
(395 Views)