Showing results for 
Search instead for 
Did you mean: 

Collection of VI's to dll?

I have a collection of VI's that relate to a machine. I would like to compile all of these to a DLL and be able to call each one via an invoke node. Something like a .net class or an activeX object. In the app builder I can build a dll but I dont want to use the call library function.


I'd like to be able to use property nodes and invoke nodes to interact with the machine.


I have several machines that use these and a single library would make life much easier.



0 Kudos
Message 1 of 9

Bumpty Bump


(Stephen King reference)

0 Kudos
Message 2 of 9

Hi Wayne,


I am a bit confused with exactly what you want to do. Do all these Vis just call commands to execute actions on another (specific) machine on your network? If you can explain your application a little more, it would help.


As far as bundling all your Vis to make it easy to distribute, you can make the all sub Vis with properly wired connector blocks and save them to a single Labview library LLB.



Eric Liauw
Senior AE Specialist - Automated Test | CLD | CTA
National Instruments
0 Kudos
Message 3 of 9

Thanks for the reply Eric.


Each VI executes a specific function. One connects to the machine, one issues move commands, etc.


They are in an LLB now. The goal is to interact with the machine using invoke nodes, not VI's.


I can make them into a class (as suggested in another forum) but I still dont know how to

use the property/invoke nodes to execute each method.

0 Kudos
Message 4 of 9

Did you use the app builder to create a .NET Assembly? If so, where are you having problems with the invoke node. You should be able to simply right click on it and select the method.

0 Kudos
Message 5 of 9

I tried that once before and LV just threw up on me (maybe it was because there was a vi with an active front panel).


I tried again and I was able to use the assembly dll in a project. However, when I run a node, LV just freezes with no indication

of whats happening.


Here are the projects. Assembly is the dll and AssemblyTest is the project that calls the dll.





0 Kudos
Message 6 of 9

You have perhaps run into this bug. I had an assembly created with 2009 and that works fine in 2010.

0 Kudos
Message 7 of 9
Thanks again for the reply. I am using LV 2010 SP1 actually.
0 Kudos
Message 8 of 9

I wanted to go ahead and confirm that this is a bug with a filed CAR on the issue.  The public workaround is referenced in the post indicated above.


Take care.

National Instruments
0 Kudos
Message 9 of 9