LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot find type library even after registering

I've waded through your KBase and discussion groups and am still unable to find a solution to the problem of Registering my type library and making LabView find it in the drop-down box.

I'm using LabVIEW 6i on a Win2000 machine. I've even used regtlib to register my tlb file and I still can't find it in the drop-down type-library list.

A temporary work-around would be to browse and point to my .tlb file , which works , but its hardly a solution when I'm developing an end-user application.

Could really use some info ! 🙂

Thanks
Shiv
p.s
I'm registered at NI with the same email id , I've asked a com-object
related support-question a few months back.
0 Kudos
Message 1 of 2
(1,765 Views)
Shiv,

You said you use regtlib to register your tlb file and it didn't work. Are you administrator on that machine? If not there's a good chance that the registry has not been edited.

You could also try to move the tlb file in a subfolder of the LabVIEW folder, it sometimes help.

Another way to check if the tlb is registered or register manually a tlb is to use regedit.exe to manually edit the registry. The key is in HKEY_CLASSES_ROOT\TypeLib in the registry. After doing this and rebooting, the ActiveX class should be there.
Be very careful when editing the registry and make sure to backup the registry log before editing anything.

Regards,

Cyril
Cyril Bouton
Active LabVIEW Developper
0 Kudos
Message 2 of 2
(1,765 Views)