Showing results for 
Search instead for 
Did you mean: 

Can't use shared variables when deploying an exe

Go to solution
I have been trying to use shared variables for some time now. I have been all over the forums and still havent had any luck. I can get these VI's to work until I install them on another PC then they don't work at all. I don't know what I am doing wrong. I have forced the libraries to deploy but they still don't work on the machine I am installing the exe on. I don't think the librarys are being installed. I can't see them in the distributed system manager. I can see libraries on other machines but not on the one I need to.
Download All
0 Kudos
Message 1 of 6
I don't know if you're having the same problem or not, but check out the solution in this thread
Tim Elsey
Certified LabVIEW Architect
0 Kudos
Message 2 of 6
I have tried the deploy invoke method still no success
0 Kudos
Message 3 of 6
Accepted by chandler

Did you include the libraries in the Always Included section of Source Files.  Did you then change the destination of the library to Support Files on the Source File Settings tab? 


In the code do you use the correct path when calling the Deploy Libraries method.   The current VI's path should be stripped twice and have "data\name.lvlib" built to the end.



Tim Elsey
Certified LabVIEW Architect
Message 4 of 6
what is the VI you are using to find the exe path? (the first sub VI in the picture)
0 Kudos
Message 5 of 6

that's what it was. wrong path for the library!!


Thanks a ton Smiley Very Happy

0 Kudos
Message 6 of 6