LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't start LabVIEW 2017, even after reinstall or Windows Restore-Point revert

Solved!
Go to solution

Has anyone ever had a problem with LabVIEW crashing on start even after you reinstalled LabVIEW (and tried Windows System Restore to revert to a point before the problem happened)?

I believe there must be some corrupt file somewhere; I've tried manually deleting the compiled-code cache and the LabVIEW INI file but to no effect.  Can anyone think of any other file that LabVIEW might read on startup?

 

2017-09-12 10_20_52-Action Center.png

 

Crossposted on LAVA

0 Kudos
Message 1 of 3
(2,153 Views)

Welcome to the Club.  Personally, I'm waiting for LabVIEW 2017 SP1 to be released before I try to install it on a machine I care about.  [My most recent attempt resulted in Bob Schor's Guaranteed Repair Strategy for LabVIEW Installations:  Step 1 -- reformat C:.  Step 2 -- reinstall the OS.  Step 3 -- reinstall Software.  I now have a working machine again, with LabVIEW 2014 and 2016 (but not 2017 -- I've learned my lesson].

 

Bob Schor

0 Kudos
Message 2 of 3
(2,087 Views)
Solution
Accepted by topic author drjdpowell

Problem fixed by deleting the entire LabVIEW Data directory.   Some file in there that LabVIEW reads on startup must have been corrupted, but I don’t know which one.

0 Kudos
Message 3 of 3
(2,085 Views)