Showing results for 
Search instead for 
Did you mean: 

Can't resize front panel objects.

I am unable to resize any objects on the front panel using the mouse; the grow boxes do not show up, and as hard as I try, I can only move an object. I can resize objects on the back panel, and I can resize on the front panel using the Set Width and Height tool. As recently as last week, I was able to resize front panel objects.
0 Kudos
Message 1 of 15
I've had problems growing objects before, but they were always on the block diagram, never on the front panel. Nevertheless, perhaps my solution for the block diagram will help you on the front panel. As strange as it sounds, whenever I can't resize something on the block diagram (it happened intermittently to me about once a day with LabVIEW 7.0, I've noticed it happens much less frequently with LabVIEW 7.1), I drop a "Format Into String" function from the String subpalette on the block diagram, then I delete it. After I do that, I can successfully resize objects on the block diagram again. Perhaps this method would help fix your front panel resizing problem.

Also, I'm assuming you've restarted LabVIEW at some point to attempt to fix the problem. Before I found the "Format Into String" solution above, I always noticed that restarting LabVIEW fixed my resizing problems.

Good luck,
DNatt, NI
Message 2 of 15
Thanks for the suggestion; however, it didn't work. I tried both the Format Into String as well as placing a new control on the front panel; neither worked. As you assumed, I have restarted LabVIEW - several times. I am using LabVIEW 7.0. Although I do have 7.1, I haven't upgraded yet because of the number of machines I would have to update software on (run-time engine, etc.). Perhaps this will be my motivating factor.
Message 3 of 15
I just solved my problem!
All of my objects are in a Tab control. I programatically change the active tab at several points and it bacame a pain every time I added or removed a tab. To make this easier on myself, I made the Tab into a strict type def control. Now I edit the control and I don't have to worry about updating all of the code to change tabs. Unfortunately, the strict type def of the tab control makes it impossible to resize objects within the tab. I changed the tab control down to type def and now I can resize objects.
Message 4 of 15
FWIW, adding then deleting Format Into String on the block diagram worked for me when I encountered the resize problem.
0 Kudos
Message 5 of 15

Works in LV 2011!

0 Kudos
Message 6 of 15

@AMyth wrote:

Works in LV 2011!

9 Years congradulations.  Not the highest I've seen but still.


EDIT: Closer to 8 1/2.

Message 7 of 15

I've never had this issue before. I recently re-installed my OS and it just started. I wonder why it even still happens. The strangest thing is the fix though!

0 Kudos
Message 8 of 15



I have a similar problem.

I have a VI with a cluster control and some other controls too.
I can resize all objects but the cluster!

I can resize object inside the cluster!

If I highlight th cluster and try to resize it with "Resize Objects" -> "Set width and height" menu it says "You cannot resize the object in this dimension".

Then I have try to move the cluster forward, Backward, To Front and To Back, but anything helps.

So what dimension is it in and how do I change it?


LV8.2.1 and LV2013


regards Bjarne

0 Kudos
Message 9 of 15

Hi Bjarne


Possible reason: the cluster is a strict type definition...


Regards, Jens

Kudos are welcome...
0 Kudos
Message 10 of 15