Showing results for 
Search instead for 
Did you mean: 

Can´t find Object I want to insert as Active X control

Go to solution

I can´t find the Thorlabs Controls (APT) when trying to insert an ActiveX Object. How can I add those objects in the list?

0 Kudos
Message 1 of 4
Accepted by topic author chhofer93

Are you referring to the Select ActiveX Class item on the right-click menu on an Automation Refnum?


If you do not find the control that you want by browsing the provided type list, then it is probably not registered on your machine.

I believe that you should be able to use the further browse button to directly locate your DLL or .ocx.

Alternativey, an ActiveX control can be registered on Windows using the regsvr32 utility, after which it should show up in the initial type list.

0 Kudos
Message 2 of 4

Okay, thank you. It works now. Maybe it didn´t work because the 32bit version of labview but the 64bit version of apt software was installed on the computer?

0 Kudos
Message 3 of 4

I am trying to find an ActiveX control supplied by my LabView course in my Uni. I have successfully installed the control and it is also registered in the device. But I am still not able to find the corresponding control in my Labview: add activeX object (Create control) list. 

0 Kudos
Message 4 of 4