LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Run 'Show Buffer Allocations...'

Solved!
Go to solution

I'm attempting to profile my program and would like to observe buffer allocations.

 

However when I go to Tools > Profile > Show Buffer Allocations...     the options is grayed out. I can't seem to select it / run this tool no matter what I do.

 

Is there some trick to this that I'm missing?

 

Thanks in advance!

0 Kudos
Message 1 of 6
(211 Views)

What's your LabVIEW level (Base, full, pro, etc.)

0 Kudos
Message 2 of 6
(191 Views)

I'm currently running:

  • LabVIEW Professional Development System 2017 Version 17.0.1, Service Pack 1 (32 bit)

 

 

0 Kudos
Message 3 of 6
(182 Views)

Any idea why this option may be unavailable to me? 

 

Or steps for me to be able to use this tool?

0 Kudos
Message 4 of 6
(138 Views)
Solution
Accepted by topic author TheRealNeil

@TheRealNeil wrote:

Any idea why this option may be unavailable to me? 

 

Or steps for me to be able to use this tool?


ASSUMING: you are using the tools menu from the Block Diagram.  There aren't any buffers on the Front Panel so, you might be seriously disappointed trying that there. 😉

 

I would suspect either that the VI properties are set to disable debugging or you have a Clone instance open rather than the VI original. 

 

Ctrl+M would switch to the VI Original.

 

Ctrl+I opens the VI Properties editor.  If the VI is Inlined you will have to deselect that before you can Enable Debugging. 

 

Otherwise: Ctrl+E opens the Block Diagram unless it is protected.


"Should be" isn't "Is" -Jay
0 Kudos
Message 5 of 6
(132 Views)

Thank you so much for this!

 

I was attempting to launch the tool from the main program window, instead of from each VI individually. 

0 Kudos
Message 6 of 6
(125 Views)