LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Can new version Add-on work with old version of LabVIEW?

Solved!
Go to solution

Hi All,

It looks like I was so naive to assuming the new version Add-on will work with old version of LabVIEW? e.g. if I tried to install vision development module 2020 with LabVIEW 2019, it won't compatible. 

 

Is it true that the Addon version must be same to LabVIEW (e.g. have to be both version 2020)?

 

Regards

Gaoke

0 Kudos
Message 1 of 4
(414 Views)
Solution
Accepted by Gaoke

In general, a toolkit will be compatible with the previous 4 releases of LabVIEW. But you can usually google "<toolkit> LabVIEW compatibility" and find a chart like this:

https://www.ni.com/en-us/support/documentation/compatibility/17/labview--labwindows-cvi-and-vision-d...

Message 2 of 4
(410 Views)

Fantastic!

Thanks for the quick reply!

0 Kudos
Message 3 of 4
(406 Views)
Solution
Accepted by Gaoke

One point to watch out! The Add-on Toolkit will normally actually check for installed LabVIEW versions when installed and only add its palette and support file to currently installed LabVIEW versions. So if you install later a new LabVIEW version along an older one, this new LabVIEW version will NOT have support for the Toolkit until you rerun the Toolkit installer again.

 

Basically all Toolkits should only be installed after the LabVIEW version you want to use the Toolkit in. And then your LabVIEW version can't be older than 3 years to the Toolkit version since Toolkits only support the same LabVIEW version they correspond to and 3 prior versions, as Gregory pointed out.

Rolf Kalbermatter
Averna BV
Message 4 of 4
(342 Views)