Showing results for 
Search instead for 
Did you mean: 

Can driver for SR830 and SR844 be used interchangeably?

Thank you mcduff!

0 Kudos
Message 11 of 29

I would also like to request your newest version saved for LabView 8.6 or before. I am using your original program but having trouble when trying to do sweeps with a SR844. Thanks for any help!

0 Kudos
Message 12 of 29

I do not have access to the source code at the moment, not until Monday at the earliest.


However, in regards to your question/problem, I never programmed/implented internal sweeps with the SR844, only with the SR850. You can either modify the program to do so, or you can use an external input to sweep your frequency.




0 Kudos
Message 13 of 29

Dear mcduff, dear Andrew,

I used the program ‏1289 KB but it seems the program does not run as it can not run the subVI properly (attached). Please suggest how to run it or select the proper path to the run the program. Thank you. 



0 Kudos
Message 14 of 29

What version of LabVIEW are you using?


Another option is to disable that part of the subdiagram and just do not save in TDMS format.



0 Kudos
Message 15 of 29


I am using LabView 2010 SP1 (32 bit), however, my operating system is Windows 7, 64 bit..  


I run the lockin amplifier (RS844) with a GPIB-USB interface and GPIB driver is from PROLOGIX (attached). 

Any advice please. 

0 Kudos
Message 16 of 29

That error has nothing to do with the GPIB driver; it has to do with saving the file as a TDMS.


I reconverted the original to 2010 version; let me know if you stil have the error or not. When I open the file, I do not have an error. I am using 2013 though.





 Just looked up the Prologix USB to GPIB; see this thread


I do not have that hardware. It looks like you will have to do some modifications to the program in order for it to work correctly.

0 Kudos
Message 17 of 29

Hi, I run the version ‏2095 KB. but it seems to me attached files/vi are missing someway. Not sure how to get these missing files..

Thank you. 

Download All
0 Kudos
Message 18 of 29
Use VIPM, and download the JKI State machine. Regards, mcduff
0 Kudos
Message 19 of 29


I have installed the JKI State machine software from the link. Good news is it solves one problem listed in my previous email. But still SubVI ' is not executable.


Now, I am using RS232 (DCE)  to USB port of the lockIn amplifier (RS844) instead port instead of the GPIB/USB adapter. But seems still the SubVI ' is not executable someway.. ... More guide please.

0 Kudos
Message 20 of 29