Showing results for 
Search instead for 
Did you mean: 

Camera Can't Connect In NI MAX

Go to solution

I am seeing a similar problem with a DRS camera pair. I just upgraded to LV2014 SP1 from LV2013 SP1, all cameras worked just fine in LV2013 with the version of MAX it ran.


MAX 14.5 is not allowing a connection to stream the data. It allows access to the attributes for both cameras, but when I click on Grab for either camera, I get a 0xBFF69001 error. So far there are no firewalls, and no security A/V software running to interfere. Only thing I see is the two PXIe GigE vision interfaces are labeled 'Public' by Windows 7.


I realize this is a different problem, but I jumped in since I am curious if he has the same 'Public' category showing for his Windows network connection.

0 Kudos
Message 11 of 20

NGC3132, make sure to update any drivers that might be associated with the camera. Go to your Control Panel > System > hardware and look at your network interface card driver update options.



--------,       Unofficial Forum Rules and Guidelines                                           ,--------

          '---   >The shortest distance between two nodes is a straight wire>   ---'

0 Kudos
Message 12 of 20

Thanks for all the responses.


@Regulator, the camera is supposed to be GigE Vision compliant, and both NI MAX and MATLab (with proper toolboxes installed) are compliant as well.  I have an A655sc camera working perfectly on the same computer.


@James.Morris, the problem with the ThermoVision Toolkit is it hasnt been updated in forever, I believe it was running labview 7?  While I didn't try it with the A6251, when I tried using it with the A655 I found it to be extremely slow.  It had lots of delay, and actually some of the benefits of the camera such as controlling it.  In my application I tell the camera to do a NUC (non-uniformity calibration) before each image I am taking.  Because of this, and the complicated/awkwardness of creating VIs with the Toolkit, I would like to avoid it if possible.


@NGC3132, for my problem, I can't even click the grab button, it is grayed out.  My error pops up after a bit of time when I click on the device in the list (timeout triggered error).

0 Kudos
Message 13 of 20

Attribute: CameraAttributes::CameraControl::SkimmingVoltage
Display Name: Camera Attributes::Camera Control::Skimming Voltage
Description: Skimming voltage in volts.
ToolTip: Skimming voltage in volts.
Type: 0x2
Availability: RW
Representation: 0x21
Visibility: 0x1000
Streamable: true
Minimum: 2.2250738585072014e-308
Maximum: 1.7976931348623157e+308
Increment: 0
Current value: 5.4999613761901855
Validating current value: FAILED ERROR: (Hex 0xBFF69012) Attribute value is out of range.
Setting current value WITHOUT validation: PASSED
Setting current value WITH validation: FAILED ERROR: (Hex 0xBFF69010) Unable to set attribute.

Attribute: CameraAttributes::CameraControl::SkimmingVoltageMax
Display Name: Camera Attributes::Camera Control::Skimming Voltage Max
Description: Maximum skimming voltage in volts.
ToolTip: Maximum skimming voltage in volts.
Type: 0x2
Availability: R
Representation: 0x21
Visibility: 0x1000
Streamable: true
Minimum: -3.4028234663852886e+038
Maximum: 3.4028234663852886e+038
Increment: 0
Current value: 6.9893519423011146e-303 ERROR: (Hex 0xBFF69011) Unable to get attribute.
Validating current value: FAILED ERROR: (Hex 0xBFF69012) Attribute value is out of range.
Unable to set current value


This is the debug file from JCat's first article.

IMax does not allow to proceed the grab due to this error.


XML file from the camera might not compatible Labview's standard.


This error is exactly same to mine..

Message 14 of 20

Wow, I tried searching through the file, and never found those errors.  I don't know how I missed that.

Time to bug Flir again. I'll update if I hear anything.


Thank You!

0 Kudos
Message 15 of 20

Drivers are all okay, latest version NI GigE Vision driver for Intel based GigE interfaces. It does not appear to be the Windows 7 Network ID name either, just changed soem settings to allow me to change it from Public to Private(work).


I also just tried a second development machine that has a 4-port Intel GigE network adapter, all loaded with latest version NI GigE vision driver from LV2014 SP1. Same exact error results seens with PXIe chassis interface.


I am now at a loss as to what it could be. I need to take thjis to my local NI Eng Rep and see if she has any suggestions.

0 Kudos
Message 16 of 20

Since my problem appears to be unrelated I will probably go back into monitoring mode, and let you guys find a solution.


But one last comment, my problem appears to be IMAQdx GigE vision connection only, I just connected a wide format IR camera on camera link, built the camera file, set it up in MAX, then fired up my custom LabVIEW code and was able to see streaming IR video in all three tools. That means I can still do the normal work here excluding any GigE vision cameras until I resolve that particular issue.


0 Kudos
Message 17 of 20
Accepted by topic author JCat

Ok, so after talking with Flir again, I found a solution.

After yoo5 found the attributes that were causing the problem (I still can't beleive I missed these), I remembered an older NI forum post that I had ran into a while back trying to fix this:


Like the person did there, navigating to the XML (mine was at "..\Public Documents\National Instruments\NI-IMAQdx\Data\XML"), search for the attributes that were the problem (i.e. <pFeature>SkimmingVoltage</pFeature>) and comment it out (change to <!-- <pFeature>SkimmingVoltage</pFeature> -->).  I did this for the 3 attributes, cleared out the PreProcessedCache folder, went back up to Data and deleted the .icd file for the camera, and re tried NI MAX and it works.


Probably more steps then neccessary, but it fixed my problems with NI MAX.  MATLab will be a different story but that is for another tech or another forum.


@yoo5, if you need more help with this, let me know

0 Kudos
Message 18 of 20

@NGC3132 My Cameras do show up as "Unidentified Network" Public in the Network and Sharing Center in Windows.  Have you run the Camera Validator on your camera yet?

0 Kudos
Message 19 of 20



I think I got it. It is good to know that NI MAX does not download XML film from the camera everytime. Thanks for the advice!


0 Kudos
Message 20 of 20