LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Call library function Node%3Alibrary not found or failed to load

Highlighted

Hello,

 

This is a question about a third part library (ttitga12100 Signal Generator) where the LabView and LabWindows CVI Driver Software can be downloaded from http://www.tti1.co.uk/downloads/drivers-download.htm.

Our measurement setup has being working just fine with this library on an older platform (labview 10 on windows XP 32-bit)  but now we are moving our measurement codes into a Windows 10 64-bit (labview 15) plattaform.

Access to instrument is done via a call to a DLL file ("Call Library Function Node") and in the new platform it outputs the following error:

"Call Library Function Node: Library not found or failed to load"

In the configure option the Library name or path field is set to "E:\projects\TTI\TGA12100\Code\Driver\Tga12100.dll" which does not exist. However this path also does not exist in the old platform and it works (the only difference is C:\ instead of E:\). I guess it is some bad programming from TTi. However even when I manually select the path to the available files (either at C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin or C:\Windows\SysWOW64) but still does not work.

 

Sorry for not deep understanding pof the problem but I would appreciate any help given

 

Best Regards

Luiz

0 Kudos
Message 1 of 7
(1,501 Views)

Are you trying to call this from LabVIEW 64 bit? Your DLL paths clearly look like they are for 32 bit DLLs and such DLLs only can be called from 32 bit applications. So you need LabVIEW 32 bit to use these DLLs.

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 2 of 7
(1,498 Views)
Dear Rolf, Thanks for your reply. The system (windows 10) is a 64-bit in a 64-bit machine but the installed labview is version 15.0.1f1 (32-bit), SP1.
0 Kudos
Message 3 of 7
(1,478 Views)

Then your DLL depends on some other libraries such as the Visual C runtime library. Each Visual C version has its own runtime library and while Windows usually comes preinstalled with at least two of them, different applications come with different runtime libraries which need to be installed.

 

Has your DLL a real installer that you can run? An installer should normally make sure that all the required dependencies are properly installed. Just copying a DLL to a different system is nowadays seldom enough to make it work on every Windows system. 

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 4 of 7
(1,475 Views)
Dear Rolf, Yes, the dll was installed using a installer (from http://www.tti1.co.uk/downloads/drivers/lv-cvi-tga12100-v1_006a.zip). In fact there are 2 installers: one for labview and another for CVI (not sure what it is). I installed both. Not sure about how updated they are. Best Regards Luiz
0 Kudos
Message 5 of 7
(1,446 Views)

Hi, I also face this problem. Do you solve it?

Best,

Lu

0 Kudos
Message 6 of 7
(699 Views)

Can you be more specific? Do you use the exact same LabVIEW driver?

Just because you see this error does not mean that you have the same problem. There are a number of reasons why Windows might refuse to load your DLL.

One is that you use LabVIEW 64 Bit but your DLL is compiled for 32 Bit or vice versa. Another is that it relies on other DLLs, either custom DLLs from the manufacturer, or C runtime libraries specific to the C compiler used to create that DLL.

So far you just told us: My car has "this" red warning light on the dashboard too and doesn't run! What's the problem?

And all we can tell you is: Sorry pal, not enough information.

Rolf Kalbermatter
Averna BV
LabVIEW ArchitectLabVIEW ChampionLabVIEW Instructor
0 Kudos
Message 7 of 7
(689 Views)