LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

CPU usage jumping to 100% for no obvious reason

Highlighted

Turn off the windows firewall then restart windows and check whether it solved.

0 Kudos
Message 21 of 29
(347 Views)
Highlighted

For me, this issue completely disappeared after replacing my HDD with an SSD.

 

I suspect that it has something to do with the fastboot option. I always ignore that warning, because I don't use hardware and I want to boot fast. But perhaps those 4 modules are sensitive to it?

0 Kudos
Message 22 of 29
(339 Views)
Highlighted

Even though my harddisk SSD, I was facing this issue. After firewall is disabled then it started to work for me.

0 Kudos
Message 23 of 29
(337 Views)
Highlighted

@avinash97000 wrote:

Even though my harddisk SSD, I was facing this issue. After firewall is disabled then it started to work for me.


Hardly a solution though... Perhaps a next step should be to allow the right processes though the enabled firewall. I wouldn't advice anyone to permanently disable the firewall.

0 Kudos
Message 24 of 29
(317 Views)
Highlighted

Thanks a lot for this hint Romain P.!

 

It is the only one that worked - short of uninstalling NI in frustration...

 

NpCap was indeed creating this problem, or rather an interaction between NI services and NpCap. Since this - pretty ancient - issue seems to still be present in current LV versions, maybe NI could actually fix it some time? 

 

Kind regards

Message 25 of 29
(236 Views)
Highlighted

@Nexus665 wrote:

NpCap was indeed creating this problem, or rather an interaction between NI services and NpCap. Since this - pretty ancient - issue seems to still be present in current LV versions, maybe NI could actually fix it some time? 


As I understand it, NI probably did not install NpCap, some other software (WireShark?) did this.  I don't think NI can be held responsible for non-NI software that the User installs that has the effect of changing the "expected" behavior of Windows sub-systems (like Networking and TCP/IP).

 

It looks, to me, that Reply 20, by "RomainP", provides the "Solution" to this question.  If you agree, please go to this Reply and click "Accept as Solution" -- this is something that the Original Poster (you) should do if a Post provides the Solution, thus helping any member of the LabVIEW Community with the same issue to know that someone has "found and posted the Solution".  It's also a very nice way to say "Thank you".

 

Bob Schor

0 Kudos
Message 26 of 29
(208 Views)
Highlighted

Hi Bob,

 

while I agree in principle that it is not strictly NI's role to fix this, IMO at least an advisory like a warning message or some documentation somewhere would not be too much to ask. Also, NI software is the only one that does this - probably due to it trying to bind to all available interfaces.

I tried selecting Romain P.'s message as the solution, but there is no link or button that lets me do this...guess it needs to be done by the OP or a mod.

 

Kind regards

0 Kudos
Message 27 of 29
(193 Views)
Highlighted

@Nexus665 wrote:

I tried selecting Romain P.'s message as the solution, but there is no link or button that lets me do this...guess it needs to be done by the OP or a mod.


Yes, it does have to be done by the OP.  Sorry that I failed to notice you had "hijacked" a previous thread.


BS

0 Kudos
Message 28 of 29
(174 Views)
Highlighted

myself and at least 3 other colleagues at work have this identical problem.  None of us have Npcap installed.  I don't have fast boot enabled in Win10 (I presume the others don't either).

 

The problem is triggered when we undock and then re-dock our laptops onto their docking station.  It is possibly triggered when the laptop's network switches from WiFi back to wired Ethernet from the dock.

We have LabVIEW 2019 installed.

 

Does anyone have any other solutions presuming Npcap is not the cause ?

 

Peter Badcock
Product Development
ResMed Ltd.
0 Kudos
Message 29 of 29
(68 Views)