LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Building application creates multiple unwanted folders

Solved!
Go to solution

Thanks all for still trying to help me with this.  I've created a brand new project and only using the 4 Report Generating Toolkits items from the other project.  I'm attaching screenshots of what now occurs and attaching this whole new project (my other project is just so massive and complicated to deal with).

Screenshot 1.jpg shows this simple code.  2.jpg shows that my project is creating the normal 3 files that I've always been used to (and I only ever need to copy my .exe application to all of our machines.  Now 3.jpg shows an error right from the very first Report Generating Toolkit VI "New Report.vi" saying that it is attempting to load it from a specific location.  This is a little different than my other project, but I believe it's still related because it's having a problem loading it when it SHOULD already be built inside my application.  It's also different because the app is actually running and then causing an error, instead of my other project where the app wouldn't even run because it was prompting to find specific files instead.

 

These 4 VIs are the exact ones causing the issues in my other project, when I remove them, my project works perfectly fine.

 

Does this help pinpoint some issue going on?

thanks,

Jesse

Download All
0 Kudos
Message 11 of 25
(906 Views)

I would expect 3 folders in your exe-folder, NI_HTML, NI_report and NI_Standard Report. I assume that hasn't changed in LV2016 compared to earlier versions.

Those folders seems to be copies of [Labview]\vi.lib\utility\nireport.llb's base folder, Standard report and Html. I wonder if you can extract them manually as a test. 🙂

/Y

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 12 of 25
(896 Views)

Hi Yamaeda, yes those are the exact 3 folders that were normally showing up in my original project and are the exact folders I do NOT want being added in that way.  I'm wanting a solution where these folder are NOT created and whatever files are needed are built INSIDE of my application like every single other VI and item in the projects.

 

I guess I'm really wanting to know why those 3 folders were created in the first place and how to stop them.  To me, it feels like there is no logical explanation to what LabView is doing when it's wanting these extra folders.  If there IS some documentation that explains this, I'd love to read it and understand it.

thanks,

Jesse

0 Kudos
Message 13 of 25
(889 Views)

I understand your original application would ask you to locate specific file dependencies before running. Now your simplified application produces error 7, basically saying the class cannot be loaded from the expected path.

 

I ran your executable and I also received error 7. I would expect error 7 to occur unless you followed the instructions in this Knowledge Base article. The files you shared so not include your build specification, so I created my own following the instructions in that article. The resulting build produced the typical exe, aliases, and ini files. The three folders you mention were not created on my system.

 

My executable runs without any problems on my machine. Unfortunately, the executable is too large to attach on this forum. I have attached my updated LabVIEW project with build specification instead. I built the application and saved the Excel file to the common directory C:\Users\Public\Documents. I imagine these directories should not affect the behavior. 

 

How is my build specification different from yours?

If you rebuild my build specification, do those three folders get created?

Does the result of my build specification produce error 7 on your machine?

Does the result of my build specification ask you to locate any missing files?

Message 14 of 25
(868 Views)

The problem is in the code (and not carefully reading the Help Documentation).  I took your program and changed the Path where the file is saved.  Ran it in development mode, it ran fine.  Built it with JesseTestingExcel.vi as the Startup, and nothing else specified.  It built fine, and crashed when it ran.  Of course it crashed -- you used the function Append Table to Report and got an error that "There is no file to which to append".

 

Replace the (wrong) function with Excel Easy Table.  It now works as you'd expect.

 

Bob Schor

Message 15 of 25
(865 Views)

Hi Bob,

Your solution did work in a brand new project.  I removed "Append Table to Report" and put in "Excel Easy Table" and there are now extra created folders and the exe opperates correctly.  I still do not understand at all why one works and the other doesn't.

 

BUT, when I do the exact same change in my main "Calibration Main Frame" project, it doesn't work at all.  I even remove ALL excel and report VIs and build it without those functions and things work and no extra folders.  As soon as I put any one of those report VIs into it and build it, back to square one and it's creating these extra folders.

 

I have no clue what to think about this situation now.

thanks,

Jesse

0 Kudos
Message 16 of 25
(852 Views)

Hi Lemongrab,

I did follow the instructions to the knowledge base article you referenced and it DID work in a brand new project.  No extra folders and the exe runs and opperates correctly!

 

BUT, as soon as I try the exact same steps for my original "Calibration Main Frame" project, I start to get errors saying "Unable to add items".  I've included screenshot 6.jpg.  This makes no sense that it is saying the path already exists in the project. You can see in my screenshot that my project has nothing else in the project except my main VI.

 

I have a feeling that LabView just has some glitch and can't do this report stuff normally in my project.

thanks,

Jesse

0 Kudos
Message 17 of 25
(851 Views)

I am glad you got the example project working. This problem sounds similiar to issues I had with older versions of the Report Generation Toolkit. Unfortunately I have never seen this behavior with LabVIEW 2016, so I am running out of troubleshooting ideas. 

 

Are you willing to share your Callibration Mainframe VI so I may investigate further? 

Was this project originally developed in an older version of LabVIEW?

Have you tried creating a new LabVIEW 2016 project and copying your code into a new VI?

Have you tried force recompiling your main VI by pressing ctrl+shif+run button?

Message 18 of 25
(840 Views)

Hey guys,

I'm beyond frustrated with this issue and WAS about to give up and just accept the fact I have to keep copying over these extra folders all the time, BUT now the exe still won't even function when it gets to the point of saving an excel file. It just pops up an error 7 saying it can't find it's files, even though they are right there in the folders it's creating!!

 

So here is my entire project zipped!  I really hope someone can figure out what is wrong with this excel junk.

thanks,

Jesse

0 Kudos
Message 19 of 25
(829 Views)

@Jesse_Larsen wrote:

Hi Bob,

Your solution did work in a brand new project.  I removed "Append Table to Report" and put in "Excel Easy Table" and there are now extra created folders and the exe opperates correctly.  I still do not understand at all why one works and the other doesn't.

 


I tried to "hint" at the solution by underlining "Append Table to Report".  If you do not specify a Report (in New Report), there is nothing to which to append (verb  -- add (something) as an attachment or supplement), and LabVIEW tells you so.

 

Sigh.  Do you remember that, until you posted your code, we couldn't see your mistake and tell you about it?  Well, your main "Calibration Main Frame" Project almost surely also has a mistake.  If you want one of us (I'll volunteer) to take a look at it and explain the error, you'll need to post it.  The easiest way to post a Project is to right-click the folder containing the Project and (I hope) all of its VIs, go to Send To, choose Compressed Folder, and attach the resulting .ZIP file.  Having the Project will allow us to also see your Build Specification ...

 

Bob Schor

Message 20 of 25
(826 Views)