LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Building LV8.5 application EXE, error 1502

Solved!
Go to solution
Highlighted

Hello,

I'm trying to build an application .exe of my LabView8.5 code. This is my first time doing so.

My VI program runs fine and has no errors.

 

However, when I try to build the application, I obtain the error

Error 1502 occurred at Invoke Node in AB_Source_VI.lvclass:Close_Reference.vi->AB_Build.lvclass:Copy_Files.vi->AB_Application.lvclass:Copy_Files.vi->AB_Build.lvclass:Build.vi->AB_EXE.lvclass:Build.vi->AB_Engine_Build.vi->AB_Build_Invoke.vi->AB_Build_Invoke.vi.ProxyCaller

Possible reason(s):

LabVIEW:  Cannot save a bad VI without its block diagram.

Method Name: Save:Target Instrument

 

To my knowledge there are no bad VI's, as the VI's run ok in LabVIEW!

Thanks for your help,

David

0 Kudos
Message 1 of 11
(4,920 Views)
Highlighted

Try going to the Additional Exclusions section of your build specification window and selecting Do not disconnect type definitions or removed unreferenced members. While this may make your execution larger, in most cases it will fix the error. 

Another option is to enable debugging. This can be done by navigating to the Advanced section of the build specification, and check Enable debugging.

 

Applications Engineer
National Instruments
0 Kudos
Message 2 of 11
(4,888 Views)
Highlighted

Thank you. 

I was able to build my .exe.

 

On trying to run this exe, I ran into the prompt for me to "Find the Shared Library Named "lvsound2.dll" ".

 

Can you explain why it is asking me to find things? Shouldn't they all have been included in the .exe? I can't distribute the .exe to my few users without everything being included.

 

Thank you for the help,

David

0 Kudos
Message 3 of 11
(4,874 Views)
Highlighted

Does your application use VIs from the lvsound dll?  Does the exe interface with the sound card at all?  If so you should see the lvsound.dll included in the Dependencies folder of your project.

Applications Engineer
National Instruments
0 Kudos
Message 4 of 11
(4,855 Views)
Highlighted

Hello,

My VI does load a .wav file, whose function I believe is located in lvsound2.dll.

 

On the Project Explorer, Items tab, I do see lvsound2.dll under the list of Dependencies.

 

I would have expected this function to be included in the .exe, but, as I mentioned, upon running the .exe it asks me to find this dll.

Sorry, have I missed something?

 

Thank you,

David

0 Kudos
Message 5 of 11
(4,844 Views)
Highlighted
Solution
Accepted by topic author Frenk

Building an exe does not actually include the dependencies, so you will either need to ensure that the dll is present on your target computer or build an installer that automatically places the dll on the computer.

Applications Engineer
National Instruments
0 Kudos
Message 6 of 11
(4,835 Views)
Highlighted

Great! It works well now. Thank you.

David

0 Kudos
Message 7 of 11
(4,812 Views)
Highlighted

dear sir,

 

i also having the same problem that error 1502. following your solution i could able to create exe but when am trying to run exe it shows tat " the vi is not executable.the full devolopment of labview is required to fix this error" .. plz help me sir

0 Kudos
Message 8 of 11
(4,603 Views)
Highlighted

saran77,

 

I had the same problem.  I was getting error 1502 when building the executable, then enabled debugging and the build was successful.  But, when I tried to run the exe, I had a broken arrow.  Clicking on the arrow resulted in "...full development required to fix..." dialog box.

 

This is what helped me:

http://www.ni.com/white-paper/11869/en/#255617_by_Category

 

I had a constant wired to a case structure.  Once I corrected this, I was able to build and run as normal.

 

Hope this helps.

Message 9 of 11
(4,492 Views)
Highlighted

Had the same issue.  Co-developers had a dozen hardcoded case statements throughout the code.  Run the VI analyzer and select just the "Unused Code" check. Find'em, fix'em and rebuild.   

Message 10 of 11
(4,286 Views)