LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Build failed "DAbort 0xF50EFD7B in MemoryManager.cpp" error

Dear All,

I'm developing a large application using the ActorFramework. It is a quite complex application that interfaces with other network systems via TCP/IP and WebServices (OPC-DA-XML).

 

When building the executable I had sometimes the “DAbort 0xF50EFD7B in MemoryManager.cpp” error message when starting the application. With a second compilation this error usually went away without changing anything.

 

Today, with a really small changes made to the software, this error continue to appear and I cannot reach to build the exe. I have noticed that the final exe file built by LabVIEW has a final size of few bytes less than the working file (24258 Kbytes vs 24471 Kbytes), but as I sayd is mostly filled by 0 hex.

 

I’m using LabVIEW 13.0.1f2 32-bit

 

Any suggestion to solve this issue will be appreciated.

Daniele

0 Kudos
Message 1 of 5
(6,211 Views)

Hi,

i haven't find any post related to this error using Actor Framework.

 

You can find information about how to do with Errors involving memory.cpp in this document:

http://digital.ni.com/public.nsf/allkb/01B186B5CEB1D07786256747000F4319?OpenDocument

0 Kudos
Message 2 of 5
(6,169 Views)

Thank Lamber for your reply.

I have temporarly solved using the CTRL-SHIFT-RUN on the main VI. I had to save 2000 VIs, but now I can produce a runnable build.

Anyway I think this is a LabVIEW internal issue that produces an empty executable with the right size.

Wait to see if happens again in the next days.

 

Daniele

0 Kudos
Message 3 of 5
(6,164 Views)

Still exists in 2016. 
I believe it has to do with loading vis with significant latency. My dev machine went to shit when everything started loading with the preface of \\localhost\c$\path to my vis\

 

I believe this happened while using tortoise svn and checking some changes against previous revisions LabVIEW caught wind of a VI and found it and proceeded to find everything next to it. 

 

I get this error when only loading the lvproj for our software or if I try to save a vi. It also may just have been a windows issue because tortoise svn also started looking up files via that path so if I could ever for a relink it then I could probably fix my dev machine. Probably why cntrl-shift Run worked.

Kyle Hartley
Software Engineer
NovaCentrix
0 Kudos
Message 4 of 5
(4,659 Views)

Kyle, we have migrated to 2015 since awhile and do not have this issue with the same project.

Anyway I still think that SVN has something to do with this and other small issues. I've seen sometimes the word "merged" when updating large parts of projects, and this has something strange to do with labVIEW binary VIs.

 

0 Kudos
Message 5 of 5
(4,650 Views)