LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Build Error - Wavelet

All,

 

   I'm trying to build my application however the build seems to not be including particular VIs. The VIs are located in C:\Program Files\National Instruments\LabVIEW 8.5\vi.lib\addons\Wavelet Analysis\wavelet packet.llb\WA Create WP Session.vi and the RunTime can't seem to find the VI for calling them. What are the proper steps to include them? I don't understand why they wouldn't be auto-included in the first place. Does the LLB make a difference? 

0 Kudos
Message 1 of 3
(1,438 Views)

Hi xkenneth,

 

The most probable cause to this issue is because LV8.5 will not automatically include all the dependent dll's of Advanced Signal Processing Toolkit to the application that you are going to build. To work around this problem, you may copy the following files from the c:\windows\system32 folder to your application folder:

 

LVWA.dll

WARef.dll

TFARef.dll 

WACore.dll

 

Please let me know if this works or not. 

 

Mac

0 Kudos
Message 2 of 3
(1,418 Views)

Besides, you can install the Advanced Signal Processing Toolkit 7.5 run-time engine in your target machine. The run-time engine can be found on the CD under runtime folder of the Advanced Signal Processing installer.

 

Another option would be to build an installer of the executable and include the Advanced Signal Processing Toolkit run-time engine from the "Additional Installers" category of the property menu.

 

Mac

Message 3 of 3
(1,410 Views)