LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Bug: Printing with Quick Print only works when default printer is set

Highlighted

When no default printer is set, it is not possible to print with Quick Print, even if an existing printer is given. The error happens inside of "Quick Print VI or Documentation.vi". Sorry for not haveing written down the error number.

 

 

This at least occures in LabVIEW 8.6.1. I can not reproduce it because I do not know how to set no default printer.

 

Greetings,

shb

0 Kudos
Message 1 of 3
(1,065 Views)

shb,

 

are you talking about the "Easy Print VI Panel or Documentation (path).vi" which is part of the Report Generation Toolkit?

 

In general, i have to confess that i am quite surprised. I've never seen Windows accepting any printers without defining a default printer. As far as i know, Windows defines the first printer configured to be the default one, with the option to swap the setting "default" to other printers if necessary.

If you don't have any printer configured in your system, you must change the parameter "report type" to HTML or Standard Report.

 

hope this helps,

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 3
(1,042 Views)

Hi Norbert

 

Yes, this is exactly the VI I am talking about.

My computer managed to loose the default printer (the checkmark). All printers were still there (and configured). I am not able to do this manually.

I agree that this is an unusual case. Also other programs than LabVIEW can not print when there is no default printer, but not all.

So this is at most a minor bug. The real problem was that I was looking for the problem in my program before suspecting the computer. (Computers are strange things. How did it manage this?)

 

Greetings,

shb

0 Kudos
Message 3 of 3
(1,034 Views)