LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Basler Ace Camera to PCIe 1473r, error in connection

Hello,

I tried to connect my Basler Ace camera to my pcie1473r. I uploaded the example to the FPGA board, but facing this error when I run the host VI:

Inline image 1

 

I looked up this issue and I tried to follow this to solve it:

http://digital.ni.com/public.nsf/allkb/4B3A1D9D33408B49862579820072775C

 

One difference is that when I open the Tools >> NI Vision >> Select CLSerNat Systems, the status of the camera is not "okay", but "software update required". Would this be a concern? What do I need to upgrade?

 

Also, do I need to install any software from the basler official website for the connection?

 

Any suggestions and comment is greatly appreciated!

 

Best,

Matthew

0 Kudos
Message 1 of 5
(803 Views)

Hi Matt,

 

What versions of software (LabVIEW, FlexRIO, FPGA, NI-IMAQ IO, and Vision Development Module). If it would be easier you can just post a MAX Technical report. Open NI MAX, File>>Create Report>>Technical Support Report.

 

Also, I've seen some cases of this software update error happening because serial communication may be blocked. Can you check if port 16505 is being block on your computer?

 

 

Matt G.
Applications Engineering
National Instruments
0 Kudos
Message 2 of 5
(663 Views)

Hi Matt,

 

Please see the Max Report!

 

May I know how to check the port?

0 Kudos
Message 3 of 5
(659 Views)

You can try disabling the firewall and see if you see the same error.

Matt G.
Applications Engineering
National Instruments
0 Kudos
Message 4 of 5
(638 Views)

Hello, 

 

Turns out it's not the firewall problem. When I connect the PoCL cable to the "base" mode connector on the camera, it can communicate with the computer.

0 Kudos
Message 5 of 5
(596 Views)