LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Autoscale problem with stripcharts

Dear all,

I am using stripcharts with two y-axis and one single x-axis. The second
y-axis was created by duplicating the first one and swapping sides, so I get
a nice chart with a proper axis to the left and the right. I would like the
user to arbitrarely set any or all of the x- and y-axis to autoscale on or
off and when set to off, the user can change the min and max scale values.
This all works fine without the second y-axis. However, with a second y-axis
on the chart, it seems that changing autoscale switches both y-axis on or
off. However, I am not sure on this as some diagrams seem to work well and
others don't. It seems to be related to the way the second axis was created,
but I am quite confused.

I just turned the program into
an excecutable and this seems to make things
worse. Autoscale now shows to be on for all axis and I can not switch any of
them off any more. My second y-axis was not set to autoscale on during then
design (as default) and does not seem to scale automatically. However, I can
not change the autoscale property for it.

I could not find a proper explanation on how autoscale really works or how
it is attached to axes objects. Anybody a hing ? I am using labview 6.i

Thanks,

Martien
0 Kudos
Message 1 of 9
(3,419 Views)
One cause of your problem is that you may not have assigned each plot correctly to the two different Y axes. On the plot legend, right click on the plot and choose Y scale. Both Y axes should be listed and you can choose which axis to assign to the plot. By default, all plots are assigned to the first Y axis.
0 Kudos
Message 2 of 9
(3,419 Views)
Dear Dennis,

Many thanks for the reaction. However, I had already assigned the different
curves (plots) to the two y-axis following the method you mentioned.
Moreover, the plots are also correctly displayed with respect to each of the
axis, so this does not seem to be the problem.

My problem is that setting the autoscale property separately for each of the
y-axis does not seem to work during the operation mode. One clue may also be
that in the design mode, I am able to set the autoscale property of each of
the y-axis separately. When running the program and I click somewhere on the
chart with the righ mouse, a menu appears with different option and on this
always the options "autoscale x" and "autoscale y" are present. There are no
two "autoscale y
" options available. A right mouse click on each of the axis
suggest that you are changing the respective "autoscale y" property of the
axis where the mouse points to, but this is probably not the case.

Any other suggestions ?

Martien


"Dennis Knutson" wrote in message
news:506500000005000000AE3A0100-1068850981000@exchange.ni.com...
> One cause of your problem is that you may not have assigned each plot
> correctly to the two different Y axes. On the plot legend, right click
> on the plot and choose Y scale. Both Y axes should be listed and you
> can choose which axis to assign to the plot. By default, all plots are
> assigned to the first Y axis.
0 Kudos
Message 3 of 9
(3,419 Views)
Have you tried setting the autoscale property from the scale legend? If you set that to be visible, you should have both Y scales listed and can autoscale either from there. I think that the right click on the graph only affects the fisrt Y axis.
0 Kudos
Message 4 of 9
(3,419 Views)
> Have you tried setting the autoscale property from the scale legend?
> If you set that to be visible, you should have both Y scales listed
> and can autoscale either from there. I think that the right click on
> the graph only affects the fisrt Y axis.

Correct. Also, this probably depends a bit on the version you are
using. I believe that 7.0 will do what you want if you use either the
scale legend or right click on the appropriate scale.

Greg McKaskle
0 Kudos
Message 5 of 9
(3,419 Views)
Martien -

Thank you for posting on the discussion forums.

I tried replicating your problem with LabVIEW 6.0.2. If your version of 6i (6.0) has not been updated, the upgrade is available for download on our website. However, the best solution would be the purchase of an upgrade to LabVIEW 7. This and many other features have been updated in the newest release of LabVIEW.

-Erik
0 Kudos
Message 6 of 9
(3,419 Views)
Thanks Dennis and Greg,

I got it to work using the scale legend (both for the development version
and the executable version). Many thanks for the tip. Using the scale legend
I also learned that in some charts my left y-axis was the first and in some
others the right y-axis, which caused some extra confusion into which one I
was modifying when setting the autoscale from the chart. I think Erik just
confirmed the issue, which seems to be solved (or at least more transparant
and clear to the user) in Version 7.0.

Once again thanks to all
Martien



"Greg McKaskle" wrote in message
news:acDub.2508$Ek.2270@twister.austin.rr.com...
> > Have you tried setting the autoscale property from the scale legend
?
> > If you set that to be visible, you should have both Y scales listed
> > and can autoscale either from there. I think that the right click on
> > the graph only affects the fisrt Y axis.
>
> Correct. Also, this probably depends a bit on the version you are
> using. I believe that 7.0 will do what you want if you use either the
> scale legend or right click on the appropriate scale.
>
> Greg McKaskle
>
0 Kudos
Message 7 of 9
(3,419 Views)

Using Labview 9 my problem is to change the default values from -1 thru' to 0 then +1 Tried property function but no joy setting y axis to autoscale the initial range is from -1 to +1. A solution would be much apprciated

0 Kudos
Message 8 of 9
(2,728 Views)

You've revived an 8 year old thread with a question that doesn't seem at all related to the thread you posted into.

 

Default values of what?  Please post your question in a new thread with more details. Even post a VI so we can see what problem you are having.

0 Kudos
Message 9 of 9
(2,721 Views)