LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Array to ColorFrame not accepting data.

Solved!
Go to solution

I am attempting to interface with a IP-cam and generate an .AVI file from the captured images taken N times per second, however I am having issues with a fundamental step, Capturing the images from my IP-cam is easy, done it for another project. When I take the image however and try to run it through IMAQ Array to colorframe it seems to reject the image data even though it is a 2-D array of U32 Values. 

 

If anyone has any ideas on why this is going on or how to resolve it can you please let me know. Thanks in advance.

Capture Frame.png

P.S. As a sidenote, if anyone knows of any decent free camera access/record programs that can access an http image, let me know and this whole problem may just dissapear.

Download All
0 Kudos
Message 1 of 4
(1,175 Views)
What do you mean that it "seems to reject the image data"? Errors?

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 4
(1,170 Views)

Sorry forgot about that, The error originating in the Array to ColorImage VI is:

 

Error  -1074369120

IMAQ ArrayToColorImage

 

Which is not very helpful.

0 Kudos
Message 3 of 4
(1,156 Views)
Solution
Accepted by topic author ogk.nz

Ok, Nevermind. After a little more looking around I found the error was coming from all the way back at the beginning with the IMAQ Create not having an image type being wired into it and not throwing an error. Thanks for the help mike. Sometimes it makes all the difference just trying to explain the problem to someone else.

0 Kudos
Message 4 of 4
(1,147 Views)