Showing results for 
Search instead for 
Did you mean: 

Arduino analog input

Go to solution


I am trying to get an analog signal from a potentiometer using Arduino UNO, but I don't see any thing on the front panel!!

I checked the port number, used both baud 115200 and 9600 and measured the potentiometer out voltage, it ranges between 0 and 5 volts so there is nothing wrong with the components but still no output on the front panel!! Any suggestion?

See please the attached picture.



0 Kudos
Message 1 of 15

Do you get anything at all or just zero?


BTW: You do know that tha Arduino analog read is only going to return a number between 0 and 1023, you need to scale this to determine what voltage that represents.


Have you tested your setup using just the Arduno IDE and the serial monitor?


I am pretty sure there is basically the same analog read demo code in the Ardunio examples folder.

Unfortunately, most readers of this Forum, including some real Experts, have not mastered the skill of being able to read the code that Posters fail to post. If we cannot see "what you did wrong", we are unable to tell you how to fix it. (Bob Schor 28 August 2018)
0 Kudos
Message 2 of 15

I get only zero and I tested it with Arduino IDE, it works.

I tried two different Arduinos and still get only zero!

0 Kudos
Message 3 of 15

So what do you see in the Arduino IDE? 

Have you uploaded the LINX code to the Arduino?

0 Kudos
Message 4 of 15

On the IDE I see results on the serial port between 0 and 1023, I do not know what exactly you mean by uploading the LINX to the Arduino!!

0 Kudos
Message 5 of 15

So the LabVIEW code that you showed is part of the LIFA packet that need a speciel LIFA code to run on the Arduino. 

What is the code that is running on your Arduino?

0 Kudos
Message 6 of 15

So as I understand from you that I have to upload the LabVIEW code to the Arduino!! if yes how can I do that, I can choose the COM, the connection type, the baud. and the Arduino type which is UNO then I hit run!

0 Kudos
Message 7 of 15

No, not the LabVIEW code, but the LIFA arduino code. There should be a LIFA ino file that you can upload to the Arduino using the Arduino IDE. 


Here is a link that explain it:

0 Kudos
Message 8 of 15

ok so now when I upload the LIFA_Base I get an error message says (( this chip is not supported))

0 Kudos
Message 9 of 15

Have you selected the right board in the IDE? 


One thing to note is that LIFA is not supported any more, this means that it might not work with the newest Arduino IDE. 

For the newest IDE, you might need to switch to LINX. 


0 Kudos
Message 10 of 15