Showing results for 
Search instead for 
Did you mean: 

Application Webservice not working since LV2021(64bit) / LV2020(64bit) was perfect

Go to solution

Dear Community


I am facing a fundamental problem since I build my big application in LV2021.


I have included a webservice in my application and build it the last "years" with LV2020(64-bit) 

After creating the installer and installing it to a clean PC everything worked fine till LV2021(64bit). The "niembeddedws.conf" was read during launch and the application was controlable via the set TCP port 8002.


Now when the same application is build in LV2021(64bit) all seems to be fine after installation but the webservice is not running. (no listening port 8002 is there)

It is not a problem of the firewall because it is completly switched off.


After starting the Application i see in the windows event log that there is a problem (but i have no idea how to investigat or even to solve this issue)

There are three error messages all related to problems with the webservice.


Here are the entries:

appweb: Error: NI Auth Module -- Caught exception while loading NIAuth shared library

appweb: Error: Initialization for module niAuthModule failed

appweb: Error: Error with directive "LoadModule"
At line 14 in C:\Program Files\ioniTOF42\niembeddedws.conf


This is the niebeddedws.conf file (hope it is ok as text in thread, i am to sure if the attached file would have been better)

# Web server configuration file.
# Generated by LabVIEW 21.0.1f1
# 16.05.2022 14:36:07

# Global Directives
TypesConfig "$LVSERVER_ROOT/mime.types"
LimitWorkers 10
LimitRequestBody 50000000
LoadModulePath $LVSERVER_ROOT/modules;$LVSERVER_ROOT/..
LoadModule niSessionManagerModule mod_nisessmgr
LoadModule niAuthModule mod_niauth
LoadModule EspModule mod_niesp
LoadModule WSRuntime mod_niws
Listen 8002

# Directives that apply to the default server
NI.ServerName "LV Embedded Web Server"
DocumentRoot "$LVSERVER_ROOT/ws_www"
InactivityTimeout 60
SetConnector netConnector
AddHandler niAuthHandler
AddHandler WSRuntime
AddHandler fileHandler ""
AddOutputFilter chunkFilter
LimitRequestForm 50000000
NI.WSRuntime.Configuration embedded "$LVSERVER_ROOT/services"
NI.WSRuntime.LoadWebService Ic_WebAPI.lvws


Hope anyboldy has a good idea as this topic is pending till LV2021(64bit) arrived and still here in LV2021SP1(64bit)


By the way, there are no webrelated NI services running and it is working with 2020. (no NISystemWebserver, and no NI ApplicationWebserver)











Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 1 of 16

Hi Gernot,


I experiencing exactly the same issue. Did you find a workaround/solution?


Kind regards


Andrea Vaccaro

0 Kudos
Message 2 of 16

Dear Andrea


I am sorry but I expected someone of NI is also looking onto the forum.


This seems not to be the case.


I still struggle with this problem and have had no step forward. The only thin I know if I install an older version of our software before I install the current version in parallel it works.


But this is no solution for this issue and I hope someone of NI is also reading this lines and states onto this issue.


If I have any updates I will post it here.

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 3 of 16

Dear Gernot,


thanks for your prompt answer. I have the same observations as you have about the workaround.


I have anyways opened an official support request. I will keep you posted about the outcome here.


Kind regards,




Message 4 of 16

Hi Gernot,


I managed to get this accepted as bug by NI with CAR number 2059713.


I am by now a CAR number champion: I got 4 accepted in 8 years. I don't know if I have to feel proud or just miserably unlucky 😂


Kind regards



0 Kudos
Message 5 of 16

Hi Andrea


Thank you for this update. Hope they will find the bug and fix ist soon.





Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 6 of 16
Accepted by topic author nottilie

I had this exact same issue and found a working solution.


In the project I got rid of my installer and made a package.  In the package build specification dialog box I checked the box in Package Installer->Create a Package Installer.  It then made the package along with a package installer and all the dependencies.  Deploying the application as a package seems to work much better.  I'm classifying the installer build specification as deprecated and they want to migrate to more of a packaged deployment solution.  I do like the CLI functionality for the NIPKG, seems like they're trying to address my use case of many tools running the same version of a software package.


Hope this helps!

Message 7 of 16

Dear Igor,


thanks for your message!!


Yes, indeed this is the workaround suggested by NI. You were faster than NI in finding a solution, it took them more than 6 months to suggest this!!


It seems also that installing software by means of the NI Package Manager is the suggested method for the future.


The bug will be fixed in the latest LV release of 2023





0 Kudos
Message 8 of 16

Indeed good news


Has somebody tried to use labview 2023Q1 and checked if it has been solved ?

The release notes of 2023Q1 are really not worth to read. 

I have not found that it was mentioned that this bug may be solved.


Eventually somebody tried it already ? 

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 9 of 16

From NI Tech support "The fix is implemented in the next LabVIEW version, which should be LabVIEW 2023 Q3 (released in the third Quarter of 2023), which obviously is not publicly available at this time. "


So no is not fixed yet. 


I do strongly advise moving to NI Package Manager installers, as suggested by Igor. I have the impression that standard installers are a dead end for NI. It took a lot of effort to convince them to fix this bug.






0 Kudos
Message 10 of 16