Showing results for 
Search instead for 
Did you mean: 

Application Builder Crash (drawmgr.cpp line 3570) when building executable

Dear forum,

currently I am working on a rather large piece of software (about 1400 sub-vis, making heavy use of user-defined classes) using labview 8.5 full dev system. When I try to build an executable the application builder stops responding and/or crashes leaving a corrupted screen and an error message like "severe error at drawmgr.cpp, line 3570" (actually I have a German version of Labview).

The application runs just fine when executed from the development environment.

I have read (, that this has been reported as a bug, but could not find any more specific information or workarounds on this issue.

Any information would be very welcome

Thanks in advance

P.S. Operating system is Windows XP (SP2) german, hardware is Athlon64(dual core), nvidia grafics card and 2GB of memory

0 Kudos
Message 1 of 5
Set the number of allowable GDI objects higher (to the max), like to say: 65,536 on WinXP or 16384 on Win2k by setting this key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\GDIProcessHandleQuota

Here is more info on the subject.

I think the default is 10000.
George M
National Instruments
Message 2 of 5
Increasing the number of allowable GDI objects to 65536 did the trick!

Thank you very much for your quick and competent answer


0 Kudos
Message 3 of 5

I was really hoping this thread had solved the problem that's been plaguing me for the past few days. It certainly changed the behavior I'm getting from LabVIEW.


Instead of resulting in a fatal error, building my project now causes the screen to flash rapidly at several points in the process, and then when the progress bar reaches the end, the build progress dialog disappears without waiting for me to click Done. Checking the build directory reveals no .exe file, and meanwhile LabVIEW has become unresponsive and has to be terminated.


Any idea what's going on? I've tried values of 65536, 65535 and 20000 with the same result. With the default value of 10000 I got the same fatal error described in the OP, which is why I was hopeful, but it's not fixed.


-- Abe Thurtell

0 Kudos
Message 4 of 5

I was having the same problem in WIN 7 LabVIEW 2016 64bit. I was trying to build an executable with more than 10000 VIs and labview kept crashing on me.

Changing the GDI limit to 20000, restarting my PC and the build the application again solved my problem.


Many thanks.



0 Kudos
Message 5 of 5