LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Application Broken with error 6208 on a particular PC

Solved!
Go to solution

I run into a strange problem with a singular Windows 10 PC - a LabVIEW application that works on every other PC we have is broken on this particular PC. When I click on a broken arrow, a message "VI has an error of type 6208The full development version of LabVIEW is required to fix the errors."

 

I only found one mention of this particular situation - https://forums.ni.com/t5/LabVIEW/VI-has-an-error-of-type-6208/m-p/957727

 

I tried uninstalling and reinstalling all NI software - didn't change.

I installed full development version - didn't change.

I installed the labview sources - they work fine within labview.

 

I am at loss.

0 Kudos
Message 1 of 23
(3,598 Views)

This is exceedingly strange.

  • There is no Error 6208.  There is also no Error -6208 (many forget to include a "-" sign if the Error has one).
  • The earlier post you reference is from LabVIEW 8 (a few years ago), and is similarly vague and unresolved.
  • If this software works on every other Windows 10 box except one, maybe you've got a weird PC.  Can you try installing it on a another machine?  Might it be a weird "hardware" thing?

Bob Schor

0 Kudos
Message 2 of 23
(3,528 Views)

Bob,

 

The error of type 6208 seems to be pretty obscure, but here's a screenshot with the latest Labview runtime:

6208.png

 

I mind that the same program on the same PC works fine in full development version, so there's no help there.

 

I even compiled it with full debug info and tried to locate the source of the error, but was unsuccessful.

I just run across a second PC with exact same problem.

 

Any help from NI in how to pin point the source of the problem?

0 Kudos
Message 3 of 23
(3,461 Views)

P.S. I wonder if the error is related to recent release of runtime engine, because both machines were just updated with latest one.

0 Kudos
Message 4 of 23
(3,459 Views)

I uninstalled Labview runtime 2019 SP1 64bit and installed Labview runtime 2019 64bit instead - everything works now with the exact same app, no broken arrow, no error type 6208.

0 Kudos
Message 5 of 23
(3,453 Views)

I run a clean test - installed LabVIEW 2019 SP1 on a brand new PC, compiled my application, and the application starts up with broken arrow. The error message after clicking on broken arrow is the same as posted above. It is not a problem with Labview 2019 or earlier.

 

I do need to resolve this issue, since this application suite is in active use in multiple research labs across the Globe.

 

Do I need to get in touch with NI tech support?

0 Kudos
Message 6 of 23
(3,406 Views)

DO you have the source code?

 

If so, search for the text of that error codes. It is in the range of custom error codes which are not defined by NI but by the developer.

 

Ben

Retired Senior Automation Systems Architect with Data Science Automation LabVIEW Champion Knight of NI and Prepper LinkedIn Profile YouTube Channel
0 Kudos
Message 7 of 23
(3,402 Views)

Ben,

 

Thanks for quick reply. I have the source code. The number 6208 does not appear to be an error code, but an error type number, whatever it could mean. I do not think is is a custom error code either since exact same behavior was reported on the forum by others before.

 

I would like to re-iterate that the application runs fine from within the LabVIEW development environment in all versions of LabVIEW tested.The application compiles into executable.The executable runs fine in all versions of runtime engine but the 2019 SP1.

 

I do not have tools to identify the reason for this run-time engine behavior. I'm wondering if NI might have them in house.

0 Kudos
Message 8 of 23
(3,397 Views)

I stripped down the application, but managed to trigger even more errors in the compiled executable (see screen shot). Could it be that LabVIEW runtime engine 2019 SP1 was shipped with some outdated dlls or missing .NET components? 

 

Fedor_0-1575939174579.png

0 Kudos
Message 9 of 23
(3,356 Views)

I made another test - built two machines, one with LabVIEW 2019 and another with LabVIEW 2019 SP1. I compiled the application on LabVIEW 2019 SP1 machine. The application compiled on SP1 machine executes fine on the machine without SP1 installed, but come up with broken arrow on the machine with LabVIEW 2019 SP1, the very machine it was compiled on. 

 

The only difference is SP1 update. I can't find a way to identify the dll or component that causes it.

0 Kudos
Message 10 of 23
(3,342 Views)