Showing results for 
Search instead for 
Did you mean: 

Anyone with any NICAN experience??

I am having two specific problems with NICAN 1.4.2.

The first is that from time to time it crashes out of LabView with a failure in "thread.cpp" at line 1813 in LV 6.0 and line 1825 in LV 6.0.2.

I have spoken to customer support and logged the problem but they have failed to sove it yet.

The second is that with my program running in either LV or as an executable it just locks up with no error messages. This happens at the second attempt of starting the CAN within my program. The only way out is CTRL-ALT-DEL.

I am not necessarily expecting resolutions for these problems, although that would of course be great, but I would like to know if anyone else has similar problems with NICAN.


Dave Nic
0 Kudos
Message 1 of 6
Dave. I experienced the thread.cpp problem too. I provided code that would cause this problem to NI. This code also showed a timeout problem for transmit and receive when using occurrences. NI is working on a new release. I briefly tested the beta release and these two problems seem to have been fixed. I have not experienced your second problem.
Hope this helps.
0 Kudos
Message 2 of 6
Hi everybody ! I'm using a NICAN v1.5 on LabVIEW 6.0.2 on Windows NT4. After 1 day using the executable, we got the same problem : Thread.cpp line 1825.I'm using are Do you think that it might be the problem ?
0 Kudos
Message 4 of 6
Hello Dave,

I'm using NICAN 1.4.2 too, and have the same error messages in LabView:
Failure in thread.ccp at line 1813 and line 1825 in LV6.0.2
and my experience is that this Problem depends a little bit on the Operating
I'm using Win NT4.0 and Win 98, and my experience is, that the Software run
much better under
Win NT4.0 than under Win 98.

In Win 98 my Software run only a few minutes, after it completly hangs (only
way out CTRL-ALT-DEL)
and in Win NT the same source code run without problems for hours, til one

For this Problem i got a solution from NI, but it seem's that the vi called
"" create this trouble.
(Now I'm using the option wait for multiple Messages, and this works)

This is only my experience with NICAN 1.4.2

Best Regar

0 Kudos
Message 3 of 6
I'm not sure with regards to the first part of your question. I have heard that there is a new version out, NICAN 1.5.x.
The second part of your question may have to deal with how you close your CAN Object.
0 Kudos
Message 5 of 6
Hi Dave
Have you tried to do this :
insert CLOSE BEFORE turn-off the CAN device.

0 Kudos
Message 6 of 6