LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Another error 1 when building an application, this time from EndUpdateResourceA

Highlighted

Just another example for NI. LabVIEW 12 has some improved error messages when a build fails, but I still often stumble on messages not telling me anything. Mentioning them should be helpful for identifying where to fix.

This time I had good luck and the build of the application succeeded on the 2nd try (without doing any modifications).

 

The error message was the following one.

 

Possible reasons:

An error has occurred. Expand the Details section for more information.

Details:

Visit the Request Support page at ni.com/ask to learn more about resolving this problem. Use the following information as a reference:
Error 1 occurred at EndUpdateResourceA.vi
Possible reason(s):
LabVIEW: An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.
=========================
NI-488: Command requires GPIB Controller to be Controller-In-Charge.

Complete call chain:
EndUpdateResourceA.vi
Write Icons to Application.vi
AB_Engine_EXE_Call_Write_Icons.vi
AB_EXE.lvclass:Build.vi
AB_Build.lvclass:Build_from_Wizard.vi
AB_UI_Frmwk_Build.lvclass:Build.vi
AB_UI_FRAMEWORK.vi
AB_Item_OnDoProperties.vi
AB_Item_OnDoProperties.vi.ProxyCaller

 

 

0 Kudos
Message 1 of 6
(3,696 Views)
Highlighted

Hi shb,

 

thanks for reporting, but what exactly can I do for you?

Your build was successful, that's great.

Did you use the GPIB driver NI-488.2 in your application? If not, it seems to be a problem with the named path.

The error message is divided in two different topics depending on what you use.

 

Best regards

Suse

______________________________
Certified LabVIEW Developer (CLD)
0 Kudos
Message 2 of 6
(3,678 Views)
Highlighted

The error happened again. While posting I realized that it is the same error message as I have posted here:

Build application still fails with error 1 in LV12

I have sent more details there.

 

@Suse: You can not do anything, sorry. This is some information for NI, not a call for help.

(While building an application (exe) a GPIB error can not occur. This are only possible reasons which are listed for any error 1. The real reason is none of them. For more details see in the thread linked above.)

0 Kudos
Message 3 of 6
(3,592 Views)
Highlighted

We have the same problem here frequently on different machines and for different applications. I wonder why there are only few posts on this issue. I am writing this while waiting on my 10th attempt to build the application to the end.

Even if the error occurs, the Exe seems to be OK and working, but without customized icon. All required support files seem to be copied into the build directory too, but then the build process removes them in the error case. So one has to copy/paste the exe into a proper environment from an earlier build.

 

It would be great if NI could fix the problem.

0 Kudos
Message 4 of 6
(3,518 Views)
Highlighted

How a fix to this problem could look is explained in Build application still fails with error 1 in LV12: add a (for) loop in vi.lib/Platform/icon.llb/Write Icons to Application.vi.

Please NI, give it a try.

 

Workaround until then: Every user running into this problem can modify the VI himself.

 

0 Kudos
Message 5 of 6
(3,330 Views)
Highlighted

Another fix is to disable your to agressive virus scanner for a moment.

Rolf Kalbermatter
Averna BV
Message 6 of 6
(3,293 Views)