LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Annoying display issue

Does anyone know how to configure LabVIEW to not change how the block diagram is displayed when opening code on a monitor with a different resolution? Below are two screen shots of the same code, just opened on different computers. One is a desktop with a screen resolution of 1920 x 1200. The other is a laptop with a resolution of 1920 x 1080, the highest resolution it has. Notice that everything gets shifted on the block diagram when opened on the laptop. This is extremely annoying. I want LabVIEW to leave everything alone. If I have to scroll because of monitor differences fine, I'll do that. Don't rearrange my code to fit in the resolution.

 

Desktop:

Desktop.png

 

Laptop:

Laptop.png

 

 



Mark Yedinak
Certified LabVIEW Architect
LabVIEW Champion

"Does anyone know where the love of God goes when the waves turn the minutes to hours?"
Wreck of the Edmund Fitzgerald - Gordon Lightfoot
0 Kudos
Message 1 of 8
(1,488 Views)

Hi Mark,

 

Does anyone know how to configure LabVIEW to not change how the block diagram is displayed when opening code on a monitor with a different resolution? Below are two screen shots of the same code, just opened on different computers.

It's all your fault… 😄

 

1. Use the same (LabVIEW) font settings on both computers. (15pt vs. 20pt!)

2. Use the same display scaling (Windows screen settings) on both computers!

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 2 of 8
(1,482 Views)

I was going to type what GerdW said basically, but as another note I think this problem may be limited to Windows 7, as I had this problem when I still used 7 but since switching to 10 I can't reproduce it.

0 Kudos
Message 3 of 8
(1,477 Views)

Company IT is very slow to update our version of Windows. We are still on Windows 7.

 

As for the rest, everything is basically default settings. I hadn't noticed the difference in the font setting but it isn't something that I intentionally set.



Mark Yedinak
Certified LabVIEW Architect
LabVIEW Champion

"Does anyone know where the love of God goes when the waves turn the minutes to hours?"
Wreck of the Edmund Fitzgerald - Gordon Lightfoot
0 Kudos
Message 4 of 8
(1,463 Views)

I would double check the font settings as GerdW mentioned. If things are at default setting, try to explicitly set the font style and size. I've run into similar things in the past and, in my case, it just looks like LabVIEW is moving things around because the font sizes effect how large the containers for bundle/unbundle, control, constant, property nodes, comments, subdiagram labels, etc are which can cause overlaps.

Matt J | National Instruments | CLA
0 Kudos
Message 5 of 8
(1,452 Views)

Just a guess, but maybe Win10 defaults scaling for different resolutions are "more forgiving".

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 8
(1,451 Views)

I remember having this exact issue when I first started using Windows 7 (from XP).  It was the new system font that caused the issues.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 7 of 8
(1,422 Views)

system fonts.  And also the font size for "scale and layout" when you look at Display Settings.

 

It is best to add to your LabVIEW .ini file (and do this on all PC's you develop on) the following items:

 

FPFont="Tahoma" 13

BDFont="Tahoma" 13

AppFont="Tahoma" 13
DialogFont="Tahoma" 13
SystemFont="Tahoma" 13

 

This should lock the size and style of the fonts for anything that is calling for a "system" font.

I also use the last 3 for any application .ini files when I build an executable.

Message 8 of 8
(1,400 Views)