LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred while communicating with the compile server.

Hello all 

 

Got a problem with compiling FPGA code. It has worked without a problem for a long time but suddenly this happens.

 

TheOtherDude_2-1613469300187.png

or this

image_2021-02-16_122439.png

First one I get when I restart compiler as admin (first run), second when I try to connect to an compiler that I have used before.

 

Everything runs on Windows 10. It is an older system with cFieldPoint and cRIO-9074 so I use

LV 2010 SP1

FPGA 10.0.1

RT 10.0.0

NI-RIO 4.0

Xilinx 11.5 (The compile worker displays: Registered Capabilities: ('Xilinx 11.5' 'Xilinx 11.5 (64-bit)') )

 

The workerLog.txt contains this:

CompileWorker.exe Error: 0 : 16.02.2021 11:23:01 Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
at NationalInstruments.NIFarm.NIFarmClient.NativeMethods.NIFarm_DownloadFile(String sessionId, String jobId, String fileName)
at NationalInstruments.NIFarm.NIFarmClient.DownloadFile(String jobId, String fileName)
at NI.LV.FPGA.CompileWorkerUI.CompileWorkerThread.ThreadMain()
CompileWorker.exe Error: 0 : 16.02.2021 11:23:01 An exception occurred: Could not find a part of the path 'C:\NIFPGA\jobs\U2z3kjj_m37oVBc\lvXilinxLog.txt'.
CompileWorker.exe Error: 0 : 16.02.2021 11:23:01 The Unit Of Work (path: C:\NIFPGA\jobs\U2z3kjj_m37oVBc) did not finish properly because of an exception: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
CompileWorker.exe Error: 0 : 16.02.2021 11:23:01 Unable to delete the final set of files. Exception: System.IO.IOException: The process cannot access the file 'C:\NIFPGA\jobs\U2z3kjj_m37oVBc.zip' because it is being used by another process.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileInfo.Delete()
at NI.LV.FPGA.CompileWorkerUI.CompileWorkerThread.CleanUpFilesCreated(DirectoryInfo zipDirInfo, FileInfo zipFileInfo)

 

I have cheked this:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kIfdSAE

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kIbRSAU

 

and tried the following without success:

- running CompileWorker.exe as administrator

- running compiler on another PC

- compiling original project that was working on the compiler in November

- creating new project with just the cRIO+FPGA and an empty VI and trying to compile it

- forcing reinstall of Xilinx 11.5 (setup.exe /reinstall) - as far as I know this installation of LV does not allow reparation/uninstallation of single module.

 

Any tips? I assume that the worst case scenario is to reinstall everything, but would like to know if there are other options and whether the re-installation can actually help in this case.

 

Regards

0 Kudos
Message 1 of 2
(113 Views)

Hi,

Maybe it will sound stupide, but have you tried to restart the cRIO device? 

and let's understand, what exactly happened. What did you changed or what was done for you to have a need recompiling it?   

 

Regards.

 

0 Kudos
Message 2 of 2
(71 Views)