LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

An error occurred trying to load the assembly labview 2020

Solved!
Go to solution

I am trying to connect Kinesis to Labview following these instructions: https://www.thorlabs.com/Software/Motion%20Control/Kinesis/Kinesis-labview.pdf

 

The .net container keeps showing an error message when I try to pull up the kinesis program. I have tried these solutions, but they seem to not work: 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P8XnSAK&l=en-US

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kFdZSAU&l=en-US

 

Does anyone know how I can get rid of the error message and actually have Labview pull up the controls? 

unnamed.png

0 Kudos
Message 1 of 3
(475 Views)
Solution
Accepted by topic author miataylor1231

Did you install the correct "bitness" of Kinesis?  If your LabVIEW is 32-bit, you need to install the "Kinesis 32-bit for 64-bit computers" version.

 

It's also best if you try it with a VI that is in a project file, and that project file is in a directory with all 100+ DLLs that come with the Kinesis driver.

 

I can verify that LabVIEW 2018 works with the DLLs in this situation with the 1.14.9 DLLs.  Anything newer I haven't tried.

0 Kudos
Message 2 of 3
(473 Views)

Ah! I just checked Kinesis and it is 64-bit while Labview is 32-bit, thank you so much!

0 Kudos
Message 3 of 3
(470 Views)