Showing results for 
Search instead for 
Did you mean: 

An error occured-The NI System Web Server is not running

Go to solution

When ever I try and open an example program I get this error.  Tried re-booting .  That didn't work.  Someting is different because example vis worked in the past.



Message 1 of 22
Accepted by topic author MarkDavid

Hello Mark.


Did you try to repair on of the NI Software you have? There is a known issue where repairing a software unregestier it from the Web Server and makes this error pop up. A solution is to repair the software again to register it anew. Here is the related Knowledge Base article:


Repairing NI Software Installs Leaves NI System Web Server Unregistered 


I hope this helped



Florian Abry
Inside Sales Engineer, NI Germany
Message 2 of 22

WOW !!  NI Germany??


Thanks..I'll give that a shot.  The only thing that bothers me is I didn't do a repair prior to this hapening.

0 Kudos
Message 3 of 22

Yes, There is also NI in Germany Smiley Wink


 Its just I was browsing the forum and had a similar case where this helped, so I though it costs nothing to share the link with you. Smiley Happy



Florian Abry
Inside Sales Engineer, NI Germany
Message 4 of 22

Thanks !!!!  That worked.  I would have never thought of that.

Message 5 of 22

I'm stuck with this same issue. Like the previous poster, I didn't knowingly repair my installation, but I did apply the patch for AMD FX bulldozer CPUs ( )... After that, labview will start, but when I try to open any example VIs, it gives me the "An error occured-The NI System Web Server is not running" message. I've gone through and repaired again, but then I need to re-apply the FX patch and I"m back to the error.


Part of my problem is that I didn't knowingly repair any of my distributions, so I don't know which one I need to run the repair on. Do I need to run it on all of them? I've just been running it on the main LV 2011 distribution.


thanks for any help.



0 Kudos
Message 6 of 22


I'm no expert but you might want to start a new thread.  I don't know how these get assigned to the AEs.  If its marked as solved they may never see it.  Hope you resolve your issue.  They've been great for me.


0 Kudos
Message 7 of 22

Thanks. I finally got it sussed. I'll post it here to save someone else some frustration. After the repair operation completes, it prompts for a reboot. Instead of rebooting, I told it "NO", then installed the FX chip patch, then rebooted. That seemed to do the trick.


0 Kudos
Message 8 of 22



We still see it, but yeah, a new thread doesn't hurt. 🙂

Ravi A.
National Instruments | Applications Engineer
0 Kudos
Message 9 of 22



this worked.





0 Kudos
Message 10 of 22