LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Agilent 53220A Frequency Counter Initialization Problem

Hello Everyone,

I am trying to communicate Aligent frequency counter 53220a with labView using USB. It is showing an error

 

"Error -1073807346 occurred at VISA Open in Agilent 532XX Series.lvlib:Initialize.vi->Agilent 532XX Series Acquire Frequency.vi"

The screenshot is attached. Can anyone please help me resolving this issue.

 

Thanks

0 Kudos
Message 1 of 5
(1,993 Views)

Hi Imran06,

 

I reproduced the error you're seeing, and here is the full text of the error:

 

Error -1073807346 occurred at VISA Open in Agilent 532XX Series.lvlib:Initialize.vi->Agilent 532XX Series Acquire Frequency.vi

 

Possible reason(s):

VISA: (Hex 0xBFFF000E) The given session or object reference is invalid.

 

This error generally occurs when your VISA resource name is incorrect, or your port hasn't been configured correctly.

 

On the Front Panel of the Acquire Frequency.vi you're using, there's a drop-down menu for the VISA resource name. If the name is blank or spelled incorrectly, you will see this error. Check NI MAX to find the VISA resource name of your device and make sure it is correct in this box.

Agilent53220A.PNG

 

If you go into the Initialize.vi on the block diagram, I would expect the error to come out of the VISA Open primitive if the resource name is incorrect:

Initialize.PNG

Jorr-El
Robotic Systems and Controls Engineer
Simplifying Automation With Industrial Robots
Certified TestStand Architect
0 Kudos
Message 2 of 5
(1,897 Views)

Hi Thank you very much for your response. I already have tried what you have suggested, but I still have the same error (see screenshot).

What I was wondering is that I can probably have some wrong setting in the VISA resource name. If so, could you please tell me how to solve?

I explain better myself: I have downloaded the drivers (for LabView8.2) from the official page, but they don't have the same version of labview that I have (LabView2011), do you mind that this could be the problem?

 

 

0 Kudos
Message 3 of 5
(1,879 Views)

Try communicating with your instrument in MAX. You will see if it shows up and if it responds to commands and queries.

 

Ben64

--------------------------------------------------
The best way to say thanks is to give kudos!
0 Kudos
Message 4 of 5
(1,865 Views)

The fact that the driver version you have is 8.2.1 shouldn't be an issue. I agree with Ben64, you should try first communicating with your device in MAX. There you will be able to see the VISA name of your instrument and also test its functionality.

 

Here's a little document that should provide some guidance on testing and seeing your USB device in MAX:

 

Connecting Instruments via USB

https://www.ni.com/getting-started/set-up-hardware/instrument-control/usb-connect

Jorr-El
Robotic Systems and Controls Engineer
Simplifying Automation With Industrial Robots
Certified TestStand Architect
0 Kudos
Message 5 of 5
(1,844 Views)