LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

After moving and resizing control, some controls don't redraw properly as the cursor passes over them.

I have a top-level VI with three panes (two splitters).  One of the panes contains nested tab controls.  One of the tab pages contains six XY-graphs, a table and some decorations.

 

I use a subVI to resize and relocate the tabs and contained controls.  All this is working fine, and everything looks fine after the resizing is complete.

 

The problem is when the cursor passes over certain controls (the chart legends and the table column headers for example), they redraw with gray boxes.  The problem only occurs after enlarging the window from its minimum size.  It goes away if the window is resized back down to minimum.

 

Anything that causes the window to redraw, like another resize or minimize/restore, properly refreshes the screen.

 

Has anyone seen this problem, and have a workaround?

 

The problem exists in development environment or built in LV 9.01 or LV 2010.

 

Thanks!

 

Matt Dennie

Download All
0 Kudos
Message 1 of 11
(3,512 Views)

Hey Matt,

 

I just looked in to your code and I am actually unable to reproduce your issue. I also looked in to outstanding bug reports and I was not able to find anything on a redraw issue of this type. These facts lead me to think that it is a computer-specific issue. I would recommend making sure you have the most up-to-date video card drivers (since it is a redraw problem). If that does not resolve your issue, I would ask that you try it on a suitably different machine, like a personal laptop if possible. If that doesn't resolve your problem, post back here.

 

Thanks,

D Smith

0 Kudos
Message 2 of 11
(3,487 Views)

Thank you for looking into it.  I actually tested the code on two different computers before posting the message and have exactly the same behavior on both.  I was concerned about the video hardware and drivers and so I made sure I tried it on different types of computers and with different versions of LabVIEW.  The two computers are a Dell Latitude E6500 laptop and a Dell Optiplex 755 desktop.

 

Just to be completely clear, the resize works fine at first.  The problem exhibits only when passing the cursor over the plot legend or table column headers.

0 Kudos
Message 3 of 11
(3,476 Views)

Ah, I thought the subVIs were resizing everything when you ran the program--I didn't realize you meant they resized things when you resized the main window. I got that effect you showed. I managed to get hold of an expert and he recommended the following:

force redraw

disable updates (on a graph)

disable front panel updates

 

if you disable and then enable front panel updates while the resize is taking place, it should properly redraw on the enable. If that isn't the case, let me know.

 

Thanks,

D Smith

0 Kudos
Message 4 of 11
(3,461 Views)

Thanks again for taking a look at my problem.

 

force redraw - This is apparently only available in LV2010.  I did give at a try, but it did not prevent the problem, nor did it correct the problem once the gray boxes appeared.

 

disable updates (on a graph) - This apparently only applies to 3-D graphs, which is not what I am using in this case.

 

disable front panel updates - I tried disabling updates before moving/resizing the front panel controls, then re-enabling updates afterwards.  The problem is exactly the same as before.  Once the move/resize is complete, passing the mouse over the table column headers or the graph plot legend results in the gray boxes.

 

I would appreciate any other suggestions you may have. 

 

Again... the problem is not that the moving and resizing don't work.  They work fine.  But once the resizing is complete, passing the mouse over the legend or table column headers causes gray boxes to appear.

 

Thanks!

 

-- Matt

0 Kudos
Message 5 of 11
(3,455 Views)

Hey Matt,  I've got some bad news for you. It looks like this is a bug in that functionality, and I will be submitting a corrective action request for this issue.

 

I do have a few thoughts, though:

 

First, it would be great if you could reproduce this problem in a more compressed size. Perhaps just resizing a single graph without any of the tabs or tables you have. At the very least, this will help R&D eliminate the bug, and at best it may help you find a workaround.

 

Second, I noticed that it seems to depend to some extent on the resolution. I would suggest looking through your VIs for anything that might limit the size bounds in some way.

 

Third, I would look and see if you have different resizing functionality for the table vs the graph. When I expand in the X direction more than about 2 inches, or diagonally with a 2" x component, I get the error with the graph key. if I expand solely in the y direction, the graph keys are fine but the table disappears and becomes gray. The difference in function may, hopefully, point to the key issue.

 

I'm sorry I can't be more help than this.

 

Thanks,

D Smith

0 Kudos
Message 6 of 11
(3,430 Views)

Once again, thanks for the help!!

 

Your description of the direction and amount of resizing that causes the problem on the graph legend and table matches my observations.

 

I've created a simplified VI that demonstrates the problem, with a single graph and no table.  It still the nested tab controls, since eliminating either of them eliminates the problem.

 

I'll keep playing with the tabs next week to see if I can work around the problem.  I need the tab-like function to switch between features and GUIs and I'd prefer not to use sub-panel VIs or other techniques that decouple the code.

0 Kudos
Message 7 of 11
(3,418 Views)

Hey Matt,

 

I've added your simplified VI to the corrective action request, and added a few notes about the tab requirement. I'll keep looking into this and I'll see if I can think of or find a workaround for you. No guarantees, of course, since this is a bug, but I will do what I can.

 

Thanks,

D Smith

0 Kudos
Message 8 of 11
(3,369 Views)

Hello,

 

I think I'm having a similar problem.  I've written a set of VI's to sequentially process and graph data, and each works individually.  Working in LV 2010 0f2 on a Mac (OS 10.6.8), I combined three VIs into a single VI with a tab control, and some tabs contain another tab control.  On the Mac version, this arrangement worked fine (and still does).  When I migrated the VI to LV 2011 in Windows XP SP3, the front panel began to slowly redraw itself every few seconds and the net effect was a strange but very annoying blinking effect.  Since then, I've tried several things with the many graphs (synchronous update, conditional disabling I've opened the VI in the Mac LabVIEW installation and the blinking/redraw problem goes away!  The problem also exists in LabVIEW 2009 (9.0.1).

 

It seems like the program is continuously updating all of the (many) graphs regardless of which tab is active (i.e., even if they aren't on the currently visible tab).

 

 

 

The user won't have to switch back and forth often, but each tab is a step in a sequence so they need to be together.  I need to deploy this software on Windows computers in either the LV 2009 RTE or the 2011 RTE.  Is there a fix or suggested work-around?

 

Thanks!

Brian



 

 

 

0 Kudos
Message 9 of 11
(3,142 Views)

Hi Poemanji,

 

I just looked into the corrective action request discussed in this thread and it is still pending a future build of LabVIEW so it has not been addressed as of yet.

 

In terms of finding a workaround I would strongly suggest creating a new thread about your issue instead of posting in a thread almost 2 years old. Your issue seems slightly different from what was discussed here and posting a new thread will give you much better visibility to the community than you will find here.

 

Also, do you potentially have an example vi or screenshot of your front panel and block diagram that you could post that exhibits this issue?

 

Regards,

James W.
Applications Engineer
National Instruments
0 Kudos
Message 10 of 11
(3,121 Views)