LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

A trouble of ISC-1780 smart camera connect computer without router

Highlighted

Hi, I have a start using NI smart camera ISC-1780 recently, my colleague helped me set up and connected it with a router, the camera is doing pattern identification through a vision builder script, it will send the packet include the object coordinate information and send it through the ethernet cable, I wrote a LabVIEW program to receive the packet, it's working well. But since we are developing a real-time system, so I tried connecting the camera directly to the computer to evaluate the speed, through windows command line ipconfig, I can see the camera IP address(but the port I keep using the one assigned in the camera), but my LabVIEW program always gives me error information.

IMG_3230.JPG

Vision Builder in smart cameraa setups

thumbnail_image.png

IP address of the camera assigned by the computer when it directly connects to the computer

I also have another problem, when we connect the camera through the router to the computer, we tried to get images from the camera through a visual assistant on the computer to develop a program on the computer instead of processing in the camera, but the visual assistant cannot find the camera, meanwhile, if we run the LabVIEW program I mentioned on the computer still can receive the packet from the camera.

Capture1.PNG

When the camera connects the computer through the router, the IP address assigned by the router.

Capture2.PNG

The visual assistant cannot find the smart camera

0 Kudos
Message 1 of 5
(154 Views)
Highlighted

With IPconfig, it tells you the IP address of the PC.  So 169.254.98.185 is the address of your PC's ethernet port, NOT the camera.

The camera will have a similar but different IP address.  169.  are "link-local" addresses which are the kinds of IP addresses assigned when there is no DHCP server to dish out numbers like an established network or router does.

 

Do you have Measurement and Automation Explorer installed?  Since this is an NI camera, the camera should show up in MAX and you can see and set its properties there.  (Assuming that the necessary camera drivers are installed, which I assume they are since you said it works when both are plugged into a network.)

 

EDIT:  Looking closer at the first image, the dialog box is showing the camera is at 169.254.72.93.  So why aren't you typing that number into your VI?  You typed in the PC's IP address which means it is trying to open a connection with itself, not the camera.

0 Kudos
Message 2 of 5
(132 Views)
Highlighted

I have tried to use 169.254.72.93 with 503 port, but it's also not working, I have used 'netstat -a' command but I can't find the 169.254.72.93 in the connection list, instead, the 169.254.98.185 is there.

I have installed Measurement and Automation Explorer but it's still can't find the camera, but still since the camera currently only sends the coordinate information, it supposes can receive it without a router, but it's not working.

0 Kudos
Message 3 of 5
(88 Views)
Highlighted

I have checked the MAX, still cannot find the camera.

yzhnasa_0-1602806147285.png

 

0 Kudos
Message 4 of 5
(73 Views)
Highlighted

You know the camera is at 169.254.72.93 when the one software is running.  So can you ping that address and see a response?  When LabVIEW and MAX say it isn't working or finding it, does the ping work then?

 

Is the working software still open when you try to run LabVIEW?  It's possible that the port is blocked because the other software still has it open.

0 Kudos
Message 5 of 5
(62 Views)