LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

8800 Thermotron TCP/IP Config settings host wont connect.

Solved!
Go to solution

I need help with configuring my laptop to talk to the Thermotron 8800 controller via a Ethernet patch cable going into the SBC.  I am not having any luck.  I have tried changing the static IP and cannot get any connection (example:(169.254.0.1)) I also tried setting up the host computer with the 127.0.0.1or (2) IP and it will not allow me as this is reserved for loopback on the host computer. This is how thermotron suggested, it is found in the Initialize VI for their Instrument vi's. There was a post here on how it will work with a DHCP router but I don't feel that is the right solution. If someone could share the settings they used on the Controller and the Host computer.

 

Snippet for the thermotron is show as well as the 127 Error that pops when you try and use that IP.

 

Thank you for your time.

LabVIEW Developer / Sr Engineer
Download All
0 Kudos
Message 1 of 3
(1,228 Views)
Solution
Accepted by topic author Maestro_Sanchez

Hi Maestro,

 

what is the IP address configured at your Thermotron?

Both devices (your PC and the controller) need to use the same IP subnet…

 

Example: when the controller is set to IP address 192.168.1.32 then your computer should be set to a different IP in the range of 192.168.1.x (excluding 0 and 255 in the last digit)…

Best regards,
GerdW


using LV2020 on Win8.1+cRIO
Message 2 of 3
(1,219 Views)

Yes I tried that, I could only change it on the thermotron software. I could not change it on the network adapter itself and maybe that was the issue. We did set the ip address to static and both the controller and host computer had different IP addresses. The status only showed as bytes sent and none received.

 

 

LabVIEW Developer / Sr Engineer
0 Kudos
Message 3 of 3
(1,209 Views)