LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

6i Upgrade & NIreports

I recently installed 6i (using the default installation) and the NIreport
tool menu is not there.
I see the llb in vi.llb/utility/ but I don't see the redistribution package
on the CD.
Has this changed in 6i, do I need to upgrade again ? Or can I use the
NIReports on the 5.1 CD.

Also, the picture tools that appeared with one of the updates in 5.1 is
also no longer there.

Any Ideas ???

Many Thanks,

Martin
0 Kudos
Message 1 of 4
(1,655 Views)
In Response to my own question:

1) NI reports are now part of the RunTime Engine, ( this note is found in
the Appbuilder Booklet !)

2) Picture Vi's (picture.llb, bmp.llb ,pixmap.llb) are installed during
AppBuilder installation. (an undocumented goodie? )

The NI Report mnu file is not loaded( at least on my system), but you
can open the m1.cab file in the LABVIEW/Installer directory on the CD and
extract the nireport.mnu and nirepadv.mnu to the menus directory to recover
the menus.
This is a standard Windows cab file.

Martin

"Martin E" wrote in message
news:3a8c6cc8@newsgroups.ni.com...
> I recently installed 6i (using the default installation) and the NIreport
> tool menu is not there.
> I see the llb in vi.llb/utility/ but
I don't see the redistribution
package
> on the CD.
> Has this changed in 6i, do I need to upgrade again ? Or can I use the
> NIReports on the 5.1 CD.
>
> Also, the picture tools that appeared with one of the updates in 5.1 is
> also no longer there.
>
> Any Ideas ???
>
> Many Thanks,
>
> Martin
>
>
0 Kudos
Message 2 of 4
(1,655 Views)
The ActiveX component of NI reports are part of the Run-Time engine not the
VIs. I have several computers with LabVIEW 6 and no App Builder but they
have all have the menus and VIs for both Report Generation and Picture functions.

"Martin Eder" wrote:
>In Response to my own question:>>1) NI reports are now part of the RunTime
Engine, ( this note is found in>the Appbuilder Booklet !)>>2) Picture
Vi's (picture.llb, bmp.llb ,pixmap.llb) are installed during>AppBuilder installation.
(an undocumented goodie? )>> The NI Report mnu file is not loaded( at
least on my system), but you>can open the m1.cab file in the LABVIEW/Installer
directory on the CD and>extract the nireport.mnu and nirepadv.mnu to the
menus directory to reco
ver>the menus.>This is a standard Windows cab file.>>Martin>>"Martin
E" wrote in message>news:3a8c6cc8@newsgroups.ni.com...>>
I recently installed 6i (using the default installation) and the NIreport>>
tool menu is not there.>> I see the llb in vi.llb/utility/ but I don't see
the redistribution>package>> on the CD.>> Has this changed in 6i, do I need
to upgrade again ? Or can I use the>> NIReports on the 5.1 CD.>>>> Also,
the picture tools that appeared with one of the updates in 5.1 is>> also
no longer there.>>>> Any Ideas ???>>>> Many Thanks,>>>> Martin>>>>>>
Message 3 of 4
(1,655 Views)
Not in my case, And NIreports is broken to boot. Font style.vi is broken,
an activeX property is not seen.
And The RTE is loaded and all.

"Dennis Knutson" wrote in message
news:3a8d4989@newsgroups.ni.com...
>
> The ActiveX component of NI reports are part of the Run-Time engine not
the
> VIs. I have several computers with LabVIEW 6 and no App Builder but they
> have all have the menus and VIs for both Report Generation and Picture
functions.
>
> "Martin Eder" wrote:
> >In Response to my own question:>>1) NI reports are now part of the
RunTime
> Engine, ( this note is found in>the Appbuilder Booklet !)>>2) Picture
> Vi's (picture.llb, bmp.llb ,pixmap.llb) are installed during>AppBuilder
i
nstallation.
> (an undocumented goodie? )>> The NI Report mnu file is not loaded( at
> least on my system), but you>can open the m1.cab file in the
LABVIEW/Installer
> directory on the CD and>extract the nireport.mnu and nirepadv.mnu to the
> menus directory to recover>the menus.>This is a standard Windows cab
file.>>Martin>>"Martin
> E" wrote in
message>news:3a8c6cc8@newsgroups.ni.com...>>
> I recently installed 6i (using the default installation) and the
NIreport>>
> tool menu is not there.>> I see the llb in vi.llb/utility/ but I don't see
> the redistribution>package>> on the CD.>> Has this changed in 6i, do I
need
> to upgrade again ? Or can I use the>> NIReports on the 5.1 CD.>>>> Also,
> the picture tools that appeared with one of the updates in 5.1 is>> also
> no longer there.>>>> Any Ideas ???>>>> Many Thanks,>>>> Martin>>>>>>
0 Kudos
Message 4 of 4
(1,655 Views)