LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

4330 error ethercat

Highlighted

Hello All,

 

While running my RT single frame program to read ENI file I am getting error 4330, details of error is given below. As part of my hardware i have NI 9144 chassis to which NI 9205 and NI 9215 are slotted. Currently i just want to read my input using slaves and obtain bit information. Could you please check the error and let me know route cause and solution for the same?

 

4330 error :

AtEmRtos.lvlib:RTOS_insertError.vi<ERR>
Error - task 'AnalyzeSystem' is scheduled and could not be disabled. This task will decrease system performance. Please do either
- start uploader with administrator rights
or
- call schtasks.exe /Query /TN "\Microsoft\Windows\Power Efficiency Diagnostics\AnalyzeSystem" /DISABLE


<b>Complete call chain:</b>

 

Screen shot:

Error.jpg

 

0 Kudos
Message 1 of 7
(1,543 Views)
Highlighted

Please attach the full VI instead of a picture of part of the VI.  We cannot "click" on a picture to see the relevant Help file, we cannot execute the picture, and we cannot see the "missing stuff" that is off the edge of the picture.  We also cannot tell what version of LabVIEW you are using (but the VI would tell us).

 

Can you explain a bit more what you are trying to do?  There are LabVIEW tools for sending data from the Remote to the Host, such as Network Streams, that work extremely well ...

 

Bob Schor

0 Kudos
Message 2 of 7
(1,536 Views)
Highlighted

Hi,

 

Please find Attached VI. Currently i just want to read my analog slaves connected. I am not sure on why the error is generated.

 

Please let me know if i need to give any other information.

0 Kudos
Message 3 of 7
(1,532 Views)
Highlighted

Hi,

 

thank you for the VI.

It seems that the Ackermann Automation lib is not a free downloadable lib. I could not find it in the internet to check your VI completly.

 

As far asI see you are trying to create an EtherCAT Master, don't you?

The NI 9144 is a Slave only device and can not configured as a Master.

Maybe that couses the error in the Ackermann VIs.

 

Best regards

Dennis

Dennis

Staff Technical Support Engineer, NI Germany


Certified LabVIEW Developer & TestStand Architect

--------------------------------------------------------------------------------------------------------

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
0 Kudos
Message 4 of 7
(1,505 Views)
Highlighted

Ok..

 

Thank you so much. I shall check on it.

 

0 Kudos
Message 5 of 7
(1,483 Views)
Highlighted

R u able to solve any further??

I am trying to do same, not succeed.

https://lavag.org/topic/19891-how-to-control-a-ac-servo-motor-using-labview/#comment-120600

 

 

0 Kudos
Message 6 of 7
(1,281 Views)
Highlighted

Hi Krishnat,

 

When me and my team analysed the error we got to know that we had problem with network adapter. So we changed adapter and set IP address to static in the network controller. Which resolved our issue.

 

Regards,

Pragathi Devaraja

0 Kudos
Message 7 of 7
(1,277 Views)