LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

3D graphs cause LabVIEW 2010 to hang

Solved!
Go to solution

On my imac i7 Mac OS X 10.6.8  with Windows 7 Ultimate SP1 running on VMFusion ver 3.1.3, LabVIEW 2010f2 would just go away if I tried to use the 3D control. If the example finder was open at the time, it would remain open but couldn't find any examples. There would be no error messages on the LabVIEW restart and nothing related in the Windows event log. 

 

Disabling 3D acceleration was the solution for me as well.

 

I found this to be curious since the VMFusion virtual graphics card is supposed to enable Open GL. So I dug around and found that when Mac OS X update 10.5.7 was released, it broke the 3D acceleration feature in VMware Fusion on Mac's with ATI graphics. As far as I can tell, it has never been fixed.   Even with VMFusion 4 and OS X Lion, users are reporting 3D rendering problems in previuosly stable apps.  

 

 

 

 

0 Kudos
Message 11 of 13
(147 Views)

I just did the upgrade from VMWare Fusion 3 to Fusion 4 (specifically, 4.0.2), and it appears that everything is working fine for me again even with 3D acceleration turned on in the VM settings and Aero turned on in Win7.

 

I haven't played around with it a lot to see if there are any OpenGL rendering ploblems, but it looks like everything is working now.

 

Travis

0 Kudos
Message 12 of 13
(126 Views)

Hi,

 

Confirmed! 3D picture control works with Display>>hardware acceleration enabled in Fusion 4.0.2 for me. I guess this is another SOLUTION. Just think, I might have unnecessarily lived without Aero, thanks.

cc

0 Kudos
Message 13 of 13
(121 Views)