LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

2012 problems building an installer

Hello,

 

LV2012 pro dev system

Windows 10

 

I am having issues building an installer when I include ni-daqmx 15 runtime with config support. 

It asks my for a daqmx 15 installer disk which I provide and it proceeds. Then it asks me for a daqmx 16 disk which I provide and then I get an error. I am not sure why it asks me for the daqmx 16 disk because I am not using this.

I am running MAX 16 with DAQMX 15.

 

I will attach a screen shot of the error it makes no sense as you can see.

 

Thanks

 

Here are my labview properties:

 

Operating System(OS) Windows 10 Professional
OS Version 10.00.14393
OS Info
Processor Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz / Intel64 Family 6 Model 60 Stepping 3 / GenuineIntel / 2394 MHz
Number of Processors 8
Physical Memory 15.9 GB of RAM
Drive C:\ 132 GB of 223 GB free

National Instruments Software: Version:

CVI 12.0.0
CVI AddOns LabWindows/CVI Shared AddOns
PID Toolkit 2.1.0
Profiler Toolkit 1.0.0
Signal Processing Toolkit 7.0.2
SQL Toolkit 2.2.0
CVI Run-Time 12.0.0.422
NI-DAQmx Device Driver 15.0.0f2
NI-DAQmx ADE Support 15.0.0
NI-DAQmx MAX Configuration 15.0.0
NI I/O Trace 16.0.0f0
IVI Compliance Package 4.4
LabVIEW 12.0.0
Advanced Signal Processing Toolkit 12.0.0
Database Connectivity Toolkit 12.0.0
DataFinder Toolkit 12.0.04910
Digital Filter Design Toolkit 12.0.0
LabVIEW Touch Panel Module 12.0.0
PID Control Toolkit 12.0.0
Report Generation Toolkit For Microsoft Office 12.0.0
System Identification Toolkit 12.0.0
Unit Test Framework Toolkit 12.0.0
VI Analyzer Toolkit 12.0.0
LabVIEW Runtime 2010 SP1 10.0.1
Measurement & Automation Explorer 16.0.0f0
Measurement Studio Visual Studio 2010 Support - See individual versions below.
DotNET
Common 15.1.40.49152
Common (64-bit) 15.1.40.49152
NI-USI 2.0.0.4901
NI PXI Platform Services Configuration 16.0.0f0
NI PXI Platform Services Runtime 16.0.0f0
NI-PAL Software 16.0.0
LabVIEW SignalExpress 6.0
NI System Configuration 16.0.0f0
NI-VISA 5.2
NI-VISA Runtime 5.2
LabVIEW Runtime 2011 SP1 11.0.1
LabVIEW Runtime 2012 f3 12.0.3
LabVIEW Runtime 2014 SP1 f5 14.0.1
LabVIEW Runtime 2015 SP1 f3 15.0.1
LabVIEW Runtime 8.2.1 8.2.1
LabVIEW Runtime 8.6.1 8.6.1
LabVIEW Runtime 2009 SP1 9.0.1

0 Kudos
Message 1 of 4
(1,425 Views)

Hmmmm, these errors often have very random causes Stewy but I would ask you whether you used the default option of letting LabVIEW choose which add-ons to include in the installer or whether you explicitly defined them in the installer options?

 

In my mind there's a potential conflict of using MAX16.0 with DAQmx 15.0  My suggestion would be to load DAQmx 16.0 on its own but there's no science to it.  Just a gut feeling based on experience of the application builder.

 

Good luck.

Simon

0 Kudos
Message 2 of 4
(1,391 Views)

Labview only automatically picks the 2012 runtime engine. Everything else is manually picked.

 

Thanks Simon I will try and install daqmx 16 but I thought I read somewhere that 2012 in only compatable with versions up to daqmx 15. I am not sure how I got max 16 with daqmx 15. Are these versions always supposed to be the same?

 

Brian

 

0 Kudos
Message 3 of 4
(1,376 Views)

Eeek, if the application builder has only picked up that the application needs the LV runtime but really it needs DAQmx etc. then it may be an indicaton of a problem further up the tree so to speak.  Have you checked that all the dependencies are OK?  It's possible that an application will compile and run on the Dev machine but with broken dependencies.

 

NI's compatibility matrix is here http://www.ni.com/product-documentation/53326/en/ and you're absolutley right.  DAQmx 16 isn't compatible with LV2012 so the answer will be just to select DAQmx 15 as this will install MAX 15 also.

0 Kudos
Message 4 of 4
(1,366 Views)