LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

cancel
Showing results for 
Search instead for 
Did you mean: 

multiple NXTs

Hello Everybody!

 

I want to run this code in LabVIEW, but don't find NXTs. I use Specify NXTs to connect the robots.

I try this description and the "Multiple NXTs" sample, but don't work in LabVIEW 2014 Module for LEGO MINDSTORMS:

http://zone.ni.com/reference/en-XX/help/372962A-01/lvnxt/multiplenxtcommuncation/

The sample program works only, when I connect robots to PC with USB and the communication is in Bluetooth. If I modify parameter to USB or connect with bluetooth, don't find NXTs.

 

Someone can help me?

 

Thanks, Adam

0 Kudos
Message 1 of 22
(6,237 Views)

Hi ythunder,

 

Did you previously connect to your Bluetooth NXTs using the "Find NXT/EV3" dialog? You can access the "Find NXT/EV3" dialog window by using the Select NXT dropdown in either the NXT/EV3 Terminal or the Robot Project Center. You have to connect to the NXTs through that interface before the Select NXT VI will work.

 

Let me know if you're still experiencing issues.

0 Kudos
Message 2 of 22
(6,231 Views)

Thanks your instant answer!

Yes, I try it from Tools/NXT/EV3 terminal. I can connect all robots both Bluetooth and USB in terminal. They are in connected state in terminal.

But in .vi I can use only one properly. When I try use more robots, don't work.

I tested my program in the Robotics Environment simulator with DANI robots and work properly. The only problem with the LEGO robots connection.

In my opinion the Specify NXT units don't work properly.

0 Kudos
Message 3 of 22
(6,227 Views)

Can you clarify when it works and when it doesn't work? 

 

I ran your program with two NXTs and one EV3, all connected via USB, and it worked fine, as far as I could tell. I had to get rid of the motor functions floating up at the top right part of the block diagram. It looked like those might have been there by accident?

0 Kudos
Message 4 of 22
(6,214 Views)

FYI it also worked for me with all three connected via Bluetooth... What's the behavior you're seeing?

0 Kudos
Message 5 of 22
(6,210 Views)

You say, that my program works via USB and Bluetooth too. Thank you for your help and your patience.
I'm not in school now. I try it two different computer (Windows 7 and Windows 😎 and with two different kind of Bluetooth tick. In the terminal I see the bricks, and I can connect them.
After that I see them connected state in terminal. But when I try to run my program I got the following error message.
Is it possible to reinstall LabVIEW and LEGO MINDSTORMS Module solve the problem? Which version of LabVIEW and LEGO MINDSTORMS Module try you my program? In school we use LabVIEW 2014, and LabVIEW 2014 Module for LEGO MINDSTORMS.

0 Kudos
Message 6 of 22
(6,205 Views)

Furthermore, could you write me which version firmware use your NXT and EV3 bricks. I remember on EV3 I use 1.05 firmware version. On NXT i can't remember.

0 Kudos
Message 7 of 22
(6,201 Views)

Hey, yeah, try getting rid of those two motor VIs in the top right of the diagram. I think that will fix the error.

 

Firmware versions are 1.06X for EV3 and 1.31 for NXT, but I don't think that's the issue here.

0 Kudos
Message 8 of 22
(6,200 Views)

You are right. I use motor controls top right of the diagram when I test a basic program with multiple NXTs and I forget to delete them after I paste my program. But I remember this test file give the same error.

0 Kudos
Message 9 of 22
(6,190 Views)

The test program has the same problem. Delete those extra VIs and it will work.

0 Kudos
Message 10 of 22
(6,187 Views)