LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 

VI freezes every few seconds for a couple seconds.

I am running LabView myRIO 2016 and the Lego Mindstorms NXT on Windows 10. The connection to the Mindstorms is through Bluetooth however I see the same behavior with USB connection as well. I have a simple VI which has a counter and displays the value from the sonar sensor. When I run the VI it pauses (freezes) every few seconds for a couple of seconds and then continues. I see in the task manager that during that time the CPU usage for LabView is zero. I don't see any other tasks using more CPU during that time. Any ideas what is going on? VI.PNG

0 Kudos
Message 1 of 9

Hi aodematt,


Does this VI has timing limitations? In the help of this VI it doesn´t say anything about it? What happens if you increase the the "wait" time or if you delete it? Does it make any difference?



0 Kudos
Message 2 of 9

I see the same problem if I increase the wait time. I changed it to 1 sec and it freezes for about 2 seconds every 5 to 6 seconds. It might be a Windows problem with accessing Bluetooth or USB however I don't know how to tell. 

0 Kudos
Message 3 of 9

Yeah it looks like...can you test it in another machine?

0 Kudos
Message 4 of 9

Not that easy but will try. I tried downgrading to LV2015 and I have the same problem. Even more a reason to investigate Windows. 

0 Kudos
Message 5 of 9

Yeah it sound like a windows issue.

0 Kudos
Message 6 of 9

Tried another computer (Low performance) with a Celeron and only 2GB of ram. I am seeing the same problem. Will try a different more powerful laptop this  week.  

0 Kudos
Message 7 of 9

It sounds like a good idea

0 Kudos
Message 8 of 9

Installing it in  new machine which had Windows 10 only and no other applications worked. This makes it look like a Windows problem. 

0 Kudos
Message 9 of 9