LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 

Type not supported in current target

We are using a vi that was originally programmed for NXT with an EV3 brick and we're having a set of errors causing the software not to run. One error is "type not supported in current target" for NI_Standard Report.lvclass:New Report We currently have 97 errors. Has anyone had a similar problem to this and could know how to fix it?

0 Kudos
Message 1 of 9

Hey there,


So the VI works properly with an NXT but not an EV3? Could you post screenshots of the VI and errors, or the VI itself?

Eden K
Applications Engineer
0 Kudos
Message 2 of 9

Hi Eden,

I'm working with afersner on this little project. The original .vi is actually freely availiable for download, but I can go ahead and upload the .vis and the sub .vis. Originally, it was developed for the NXT but we have an EV3 and was under the assumption that it was backwards compatible. I'm beginning to suspect it isn't.


0 Kudos
Message 3 of 9

Hi bruizy,


There are multiple types and functions in the NIReport library that are not supported on the EV3 or NXT targets. I believe that this VI must be run Target to Computer (in File menu) on both the EV3 and NXT.


Any LabVIEW primitive and type that is compatible with NXT is also compatible with EV3.

Message 4 of 9

Hi Garrett,


That makes sense. I had tried running it target to computer earlier, but it times out when trying to connect to the EV3. I've tried both through USB and through bluetooth, and it just errors out with the following code.


Error -142016 occurred at


One thing I noticed, or am beginning to suspect, is that it seems to not ever try to connect via USB and always tries to connect via Bluetooth. I'm not sure how to force it to connect via USB aside from turning off all bluetooth connections, but when I do that it just hangs on "Getting Bluetooth Connection" forever. It won't even time out this time.

0 Kudos
Message 5 of 9

How are you establishing the connection? Are you using a Robot Project? Bluetooth connections are not made automatically, but USB connections can be. Do you see an item with the same name as your EV3 in the dropdown?


I am surprised you are seeing an error with the text "createNXTIterator" using an EV3. What version of the LabVIEW Module for LEGO MINDSTORMS are you using?

Message 6 of 9

The Labview module should be the latest version. I updated everything to the latest version and I also flashed the firmware on the EV3 to the one that Labview was pushing out, 1.06X. We had it continue after receiving those errors and it told us to help it find a device, which we did, but now we are reaching a point where it isn't creating an "NXT Object."

0 Kudos
Message 7 of 9

An update to the topic (since for some reason I can't edit my post). We started going through the VI piece meal and have seen that when we connect the EV3 via USB or Bluetooth that we get to different points where a failure occurs. With the USB it seems like the Fantom drivers aren't reading the EV3 properly and with the Bluetooth connection we see that there is an error in a subvi that we can't find called I've noticed that some people have mentioned issues with connectivity with Windows 10, but I'm not sure if that is related to our issue.

0 Kudos
Message 8 of 9

Given the mentions of Windows 10 issues, do you by any chance have a Windows 7 PC you could try it with? When you get that error with the Bluetooth and choose "Show Error" does it not properly direct you to the sendreceivemessage VI?

Eden K
Applications Engineer
0 Kudos
Message 9 of 9