LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 

Lego NXT - Continuous Servo VI Error

I am working on a program for an First Robotics FTC competition that our team will be at next week and I think I have found a bug in the VI's provide for Continuous Servos.  I have attached images that show what I am doing and the error I recieve.  The issue appears to be in the providded Move ContinuousServo VI and is a type cast issue.


I am going to try to get around this issue by modifying my Schematic to include regular Servos instead of Continuous Servos.  I think this would make these work as they did in previous versions of LabView where you have to use 0 - 255 to control the speed of the Servo.  If this doesn't work I am not sure what else to do.  Our robot is dependant on this functionality and as I said we have our qualifying competition next week.  Any help is appreciated.

0 Kudos
Message 1 of 6

Hi Eddie,


It looks like you did find a bug. Here's what to do: First of all, if you hit the continue button on the error dialog, the program will run anyway, so you don't need to mess with the schematic.


To make the warning go away, make the file with the double constant writable, then right click on the costant and choose Representation>>Single Precision. Then save the VI.



Message 2 of 6

Thank you so much for you quick response.  I could not figure out how to make the VI editable (I apparently totally missed the writable flag when lookig at the file properties).  When I tried to continue I did not think that the NXT got loaded with my latest version, but I never actually tried it becuase i was not with the robot at the time.  I will check this out tonight and let you going if I get it fixed.


Again, thanks for the repsonse!



0 Kudos
Message 3 of 6

Hi. Here's how to make the VI writable. If you're on Windows, in the Windows Explorer, right click on the item and choose Properties and uncheck "read-only" in the Attributes. Then, in Labview, if you cannot edit the block diagram, then press ctrl+E to edit. 

0 Kudos
Message 4 of 6

I verified that just "continuing" works and for the moment that is good enough. 


However, no matter what I did I could not edit the problematic VI.  I am using Windows 8.1, set the file to be writable, and tried ctrl-e.  All I seemed to to be able to do was "probe".  If you have any ideas it would be appreciated.

0 Kudos
Message 5 of 6

Sure. Ctrl+e should generally do the trick when the VI is not running or waiting to run. To ensure that it isn't running or waiting to run, you can try quitting LabVIEW and then just opening that VI before running anything.

0 Kudos
Message 6 of 6