LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 


I have  a serious problem and would appreciate your help. I am working with LabView 7.1.1 Student edition and with the labview NXT toolkit. I have been trying to acquire data using NXT Mindstorms. All was going fine until the NXT module connected to my pc through USB stopped responding; the module does not turn on and the problem is not lack of battery. It does however let out a low clicking sound similar to a clock?! I suspect that it lost it´s software or it´s memory ; is this possible?  I must add that this is the second time this problem occurs with LabView 7.1.1. Last time I sent the NXT module to the technical support center here in Portugal and they gave me a new module, insisting that I must always use original software. Although I do have the original software, LabView is ideal for the task at hand. What should I do? Can I resolve this situation on my own?
Thankyou for your time
0 Kudos
Message 91 of 139
Your diagnosis is pretty close.  It sounds like your NXT is somehow getting into firmware update mode.  To fix this, hold down the button deep in the technic hole just below the USB connector for approximately five seconds.  Your NXT should then start to click softly, as you described.  In the MINDSTORMS software, select the option in the menus (I forget exactly which menu) to download new firmware.  Once you've downloaded the new firmware, the NXT should automatically reset itself into normal mode.

If you don't have the MINDSTORMS software, there's probably a way to do this with the NXT toolkit, but I don't know it off the top of my head.  If you need more help, you can search the web for "lego clicking brick syndrome" and find several additional resources.

One remaining question: what is causing your NXT to enter firmware download mode?  Are you calling a toolkit VI that might be causing that?

Finally, since your post was a question and a request for advice rather than a specific bug report, it would have been better to start a new topic rather than add to this one.
James Blair
0 Kudos
Message 92 of 139
Thankyou James for your advice, it was useful for resolving my problem. In fact, I think something is actually wrong (bug?) with the NXT toolkit or my version of Labview (7.1.1 student edition). I dont't understand why sometimes it works and  other times I loose the NXT firmware. Here goes a print screen of what I'm working with so that you can understand more clearly (
Best regards,
0 Kudos
Message 93 of 139

LabVIEW is parallel in nature.  In your vi it is not clear which of the two commands is executed first and which is second.
You can easily force this by connecting the error out of the first to the error in of the second vi.
And also create an error indicator at the error output of the second vi.
The error messages that appear will help you in debugging.
A less optimal solution is the use of sequence frames, but that will also solve the execution order problem.
It even can be possible that both vi's run at the same moment if you have a dual (or more) core computer.
Although I believe that some provisions are made in the toolkit to minimize that.

good luck with LAbVIEW programming.

By the way, this connecting of subvi's by either the error line or some other wire that feeds information from the first to the second is called "sequencing by wire" and is the optimal programming style in LabVIEW.
greetings from the Netherlands
0 Kudos
Message 94 of 139

Thanks so much for this tip and link, it solved my problem as well.  I am so happy.  I have tried to fix this problem on my Mac forever and now it is fixed.  :smileyhappy:


James Ramsey 

0 Kudos
Message 95 of 139

I use LabView 8.0 (German version), LabVIEW Toolkit for LEGO MINDSTORMS NXT and nxt_toolkit_1_0_1_patch on Windows Vista. Mass compilation was whithout errors.

If I try to compile some VI's, I get the error message "Unsupported case structure value. Only single value cases and Default, are supported." I think, this problem was solved with nxt_toolkit_1_0_1_patch ???

0 Kudos
Message 96 of 139

Easymac wrote:
I am running Labview 8.2 with the LEGO mindstorm tool kit. My hardware is a macbook pro with 10.4 Labview is running fine, everything is compiled and running on rosette, but whenever i try to open the nxt terminal, Labview quits. I have reinstalled Labview twice and the NXT tool kit three times, but the same problem occurs. ?
Yeah I've been having the exact same problem, except that I have 10.5 on my macbook. Can anyone help? 


0 Kudos
Message 97 of 139

I found a bug in the Qoutien & Remainder, when using nagatives input.

I have made this workaround to get the same result on the NXT, as it was intendet on the PC.

I think it is a serius bug, and i find i strange that no one have encountered the bug before.

I am using LabVIEW 8.0 with NXT Firmware 1.05.

LabVIEW 2009 and 2011 user, with LabVIEW toolkit for Lego Mindstorms NXT.
0 Kudos
Message 98 of 139

Are there anybody, who can reproduce this bug?

Is this something NI/LabVIEW will make a patch/update to fix?


Best regards


LabVIEW 2009 and 2011 user, with LabVIEW toolkit for Lego Mindstorms NXT.
0 Kudos
Message 99 of 139

Thank you for reporting this issue!


I was able to reproduce the bug. On NXT, the quotient and remainder function returns a different set of values from when running it on PC, if one of the input is negative. We'll fix it in the next release of the NXT toolkit.


If we are only talking about quotient and remainder, the values returned on NXT are not wrong either. But the LV PC "quotient and remainder" returns the floor of "quotient", and calculate the remainder using the floor of the quotient, as indicated by the labels of the indicators. Since the "quotient and remainder" function on NXT inherits the names of the indicators from its PC version, it should be consistent with the PC version.

0 Kudos
Message 100 of 139