LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW 2013 Student Edition and EV3 Firmware mismatch

Hi,

Sorry if this has been asked before, I looked around and could not find any solution.  I have LabVIEW 2013 Student Edition and a LEGO Mindstorms EV3.  When I try and connect the 2 it says I should update my firmware on either the EV3 or the add on module NXT/EV3.  I have downloaded and added the 2013 version for the add-on module.  If I upgrade the EV3 it will bring it to 1.09H (newest firmware) where it is currently at 1.07H.  The firmware I believe it would need to be to match the LabVIEW 2013 which might be 1.05. I would rather upgrade the firmware for the module than downgrade the firmware on the EV3.  Is this possible?

 

Thank you,

 

LW

0 Kudos
Message 1 of 6
(5,458 Views)

Hi lisjwil43,

 

I have been looking into this, and I came across this forum post where there are many questions about upgrading the firmware:

 

http://robotsquare.com/2013/07/16/ev3-nxt-compatibility/

 

Based on this, I think it should be fine to do an upgrade, and that might resolve the issues. Either way, if you do an upgrade and it does not work correctly, you can always downgrade to the 1.05 version later if needed.

 

Cheers,

Ryan

0 Kudos
Message 2 of 6
(5,401 Views)

Would you know how to upgrade the LabVIEW module?  It Is not apparently clear to me.

Thank you!

 

 

lisa

0 Kudos
Message 3 of 6
(5,392 Views)

It turns out I ended up downgrading the EV3 Firmware to 1.05 after upgrading to 1.09h and testing LabVIEW 2013 and it still did not work,

 

it it does however work with the firmware 1.05.  I guess for me to upgrade the driver, I will probably have to upgrade the software.

0 Kudos
Message 4 of 6
(5,389 Views)

How can i downgrade from EV3 v1.09H ?

0 Kudos
Message 5 of 6
(4,469 Views)

Hey Pat,

 

You can use the EV software to manually select an older firmware version.

 

Bdog

0 Kudos
Message 6 of 6
(4,463 Views)