LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

Showing results for 
Search instead for 
Did you mean: 

Error Compiling the second programm of the tutorial

Hello everybody,
I am a French student so excuse me for my bad English. I am currently working on the NXT Toolkit with Labview 8.2.1
I try to compile the sencond programm given in the tutorial which returns the value of the battery but I have these errors when I try to compile it.
ERROR: Indexing tunnels are not supported.
ERROR: An error occurred during parsing. Node was unable to be parsed. ((Class: CompoundArithmetic)  (VI:
ERROR: An error occurred during parsing. Node was unable to be parsed. ((Class: CompoundArithmetic)  (VI:
ERROR: Can't open SubVI. (
Do you know where is the problem? What can I do to solve it?
Thank you for your answers.
0 Kudos
Message 1 of 7

It seems to be a problem with NXT Direct Commands 😞

Is it possible to have some examples of progams made with the NXT Toolkit because I don't have found more tutorials?

Thank you.


0 Kudos
Message 2 of 7
I'm not sure I can identify the root cause of your problems, but I can make a couple of suggestions. I'm also not sure how much experience you have with LabVIEW, so let me know if you need more detailed info.

The indexing tunnels error probably means you tried to wire an array into a for loop or a while loop. Right-click on the terminal where the wire crosses the loop boundary and disable indexing.

Not sure about the parsing errors.

On the error, try locating that file and opening it yourself.  Maybe the file didn't get installed correctly, or maybe trying to open it will give you more information about what the problem is.
James Blair
0 Kudos
Message 3 of 7

Hello James B.

Thank you for your answer.

I have tried to see from where comes the "Indexing tunnel" error. It comes from the . In fact, there is an array wired in a while loop but I don't have created it. It is a vi from the NXTToolkit.

About the parsing errors, there are in the same file in the while loop.

In fact, the is not installed. I don't have found it on my hard disk.

I have fond a similar problem in the forum here

It looks like to be a problem with the mass compile. I have tried to re-install Labview and the NXTToolkit and I have always the same problem.

Thank you 



0 Kudos
Message 4 of 7
So, did mass compiling the NXT toolkit directory help at all?
James Blair
0 Kudos
Message 5 of 7
It looks like you're trying to compile a VI that uses direct commands to the NXT.

The direct command VIs run on the PC and so, you should use the regular LabVIEW run button (that is on the block diagram and front panel windows) rather than the run button on the NXT Terminal.

Does this help?

- john
Message 6 of 7
Thanks a lot John Field,
It was my problem. I made a mistake between these 2 buttons. I'm very stupid Smiley Very Happy
Thansk James B. for your help too 😉
0 Kudos
Message 7 of 7