LabVIEW for LEGO MINDSTORMS and LabVIEW for Education

cancel
Showing results for 
Search instead for 
Did you mean: 

Does Mindstorms Module 2016 Use My Documents Location?

Solved!
Go to solution

I'm experiencing an annoying problem where I cannot run Mindstorms Module 2016 VIs under LabVIEW 2016 on my EV3 when using my Windows 10 work laptop while on my home network. I believe this could be because My Documents is network-based due to my employer's group policy and so My Documents is only accessible when I am logged into my employer's network.  If Mindstorms Module is looking for My Documents and it's not there, it crashes with this error message:

Mindstorms_Error.jpg

 

Note that this is only a problem in Direct Mode (i.e., with code running on the EV3) and seems fine in Remote Mode (where code runs on the PC and uses the EV3 as slave I/O hardware, as I understand it).

So, does the Mindstorms 2016 Module use My Documents for storage by default?  And more importantly, can I change this preference somewhere?

Thanks in advance.

0 Kudos
Message 1 of 4
(5,212 Views)
Solution
Accepted by Joel777

It could be written in the code, and if that was the case you could alter it there. If it is referring to a default director you can change that by opening your LabVIEW VI, select Tools > Options > Paths. Then change the default path that is causing the issue. The default for 'Default Data Directory' is C:\users\[name]\Documents\LabVIEW Data.

 

If you could attach the VI it may give a better insight into what the code is doing.

 

Best,

Aaron F.

National Instruments

0 Kudos
Message 2 of 4
(5,176 Views)

Frankay,

Changing my LV data directory to a local drive path fixed it, thanks!  I assume LV will re-create any important content in the new directory, right?  I hesitate to copy any files from old folder to new for fear of LV getting upset or confused.

Changing this path also fixed another phantom problem that was obviously related but ignored by me: "Failed to create directory for auto recovery VIs" nagged me on LV startup when away from my work network.  Quick web search tells me that symptom is also caused by LV not finding the documents directory.  Great lesson to share with my students: Consider ALL symptoms, no matter how small, since they may be related.

Probably a moot point now, but I've also attached the VI, which is simply one of the canned examples provided with the 2016 Mindstorms Module.

Thanks again,

Joel

0 Kudos
Message 3 of 4
(5,167 Views)

Not a problem Joel, I'm happy I could help! That is an excellent point and great lesson to share!

 

Best,

Aaron F.

National Instruments

 

 

0 Kudos
Message 4 of 4
(5,128 Views)