LabVIEW Web UI Builder and Data Dashboard

Showing results for 
Search instead for 
Did you mean: 

Data dashboard QMH

Go to solution



I have made a program using the Queued message handler (QMH) based on the continuous measurement and logging example shipped with LabVIEW 2013.

I want to view and control this program by using the Data dashboard with web services (for Ipad). I followed this tutorial;

Using this tutorial I am able to connect my desired controls and indicators to the data dashboard.

But when I am running the data dashboard, it does not interact with the program. If I however run the web resource vi from within the program itself if works.

I have made a dummy vi that just creates a random number and this is working fine, using the Data dashboard web services.

Does anybody know what I am doing wrong?


Kind regards

0 Kudos
Message 1 of 7


After I made the executable with the web services I do not see the web service on the data dashboard.

So instead of working with the executable I just right clicked the web service in the project explorer and published the web service, this way I am able to see and connect the indicators and controls to my dashboard.




0 Kudos
Message 2 of 7
Sounds like it might be related to a difference in the port the Web Service is hosted on. That may change between LabVIEW and the built EXE. Good news is you can set that up to be the same port of you so choose.
NI App Software R&D
0 Kudos
Message 3 of 7

I`m not entirly sure what you mean.

While building the EXE I have set the port for the web services to 8080.

In the web server configuration I have changed the application web server to port 8080 as well.

But the data dashboard still doesn`t see the web services when I search for port 8080.


0 Kudos
Message 4 of 7
Accepted by topic author bdmar
08-27-2015 04:09 PM

I would try setting the Web Server port for the EXE to a different number; something far away from the standard 8080. Then make sure Data Dashboard is targeting the port for your EXE and not your project.


I have never tried setting two Web Servers to run on the same port, but I have had issues with port conflicts (using the same port for the Project and resulting EXE) using VI Server. 

Zach P.

Staff Software Engineer | LabVIEW R&D | National Instruments
0 Kudos
Message 5 of 7

I have asked my netadmin to open port 8002 (standard for EXE web server)

I am now able to connect the data dashboard to the EXE.

But my indicators are not updating, I just get an error after a couple of seconds, although they are linked to the web resources VI`s.

I am using an android tablet today if that matters, I get the Ipad back tomorrow.


0 Kudos
Message 6 of 7

After deleting the EXE en rebuilding it, it works using port 8002.

Thanks for the advice!



0 Kudos
Message 7 of 7